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LIST OF ACRONYMS 
AND INITIALISMS
CAPI – Computer Assisted Personal Interview

CRS – Coordinates Reference System

CSV – Comma Separated Values
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GIS – Geographic Information System

GPS – Global Positioning System
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1 OVERVIEW AND  
INTRODUCTION

1.1 Background to  
the Manual
The population and housing census is among the most complex and 
massive peacetime exercises a nation can undertake. It requires mapping 
the entire country, mobilizing and training a large number of enumerators, 
conducting a public advocacy campaign, canvassing all households, 
compiling vast amounts of data in paper or electronic form, and analysing 
and disseminating data. By definition, a population and housing census is 
an enumeration of the total population of a country, which provides data 
on numbers of people, their spatial distribution, age and sex structure, 
their living conditions and other key socioeconomic characteristics. 
Such data are critical to national and sub-national development planning, 
tracking progress for the Sustainable Development Goals (SDGs), the 
distribution of infrastructure and social welfare programmes, election 
planning and market analysis. 

A wide variety of technology solutions for census data collection, analysis 
and dissemination have emerged. These solutions range from the use 
of the internet, laptops, hand-held or tablet computers, Geographic 
Information Systems (GIS), and scanning and recognition systems. 
Enumeration area and household mapping techniques have progressed 
from paper lists to integrative methods using GIS, the global navigation 
satellite system and Digitized maps. Data capture has evolved from 
the manual keying-in of data to the use of scanning technologies with 
imaging and paperless capture via electronic questionnaires. Census 
data processing has evolved to include advanced analysis techniques 
and visualization software, electronic dissemination platforms and 
interactive web-based tools for dissemination and analysis. New and 
emerging technology solutions for census provide ample opportunities 
to improve the quality, cost effectiveness and timeliness of the census 
operation. In order to capitalize on these technology solutions, National 
Statistical Offices must make timely, strategic choices to adopt context 
relevant solutions.
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Adoption of new emerging technologies requires robust up-front 
investments by National Statistical Offices and the international 
statistical community. Flexibility and willingness to embrace change 
will be required for the successful utilization and integration of these 
innovative techniques. 

This manual "QGIS for digital cartography in censuses and surveys" 
responds to demand by countries that international cooperation 
promotes national capacity-building and recognize national ownership 
and leadership as prerequisites for development, in accordance with 
the principles agreed at the International Conference on Population 
and Development and the 2030 agenda. With the adoption of the 2030 
Agenda, we agreed to enhance capacity-building support to increase 
significantly the availability of high-quality, timely and reliable data 
disaggregated by income, gender, age, race, ethnicity, migratory status, 
disability, geographic location and other characteristics relevant in 
national contexts by 2030. 

This manual is the result of a global collaboration between the United 
Nations Population Fund (UNFPA) and the Pacific Community (SPC). 
This manual was developed in an effort to strengthen capacities of 
National Statistical Offices to generate, analyse, disseminate and utilize 
high quality, timely, relevant, and disaggregated geo-referenced census 
and survey data to inform, implement, monitor, and evaluate sustainable 
development for the public good. The manual covers all stages of digital 
mapping, including plotting of households within Global Navigation 
Satellite Systems (GNSS), creation of administrative boundaries, 
production of supervisor and enumerator maps, basic spatial analysis, 
and image processing, it provides National Statistical Offices alternatives 
to commercial software for digital cartography in censuses and surveys.

1.2 Introduction to QGIS
QGIS is a free and open-source geographic information system. This 
means that no license or purchasing process is necessary to start using 
the software.

Why was QGIS chosen for this manual?

• It is free and open source.

• It is user friendly, easy to learn and has a significant amount of 
support and external resources, such as:

• QGIS documentation: https://docs.qgis.org/3.10/en/docs/

https://docs.qgis.org/3.10/en/docs/
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• QGIS training manual: https://docs.qgis.org/3.10/en/docs/
training_manual/index.html

• Users and developers community: https://gis.stackexchange.
com/?tags=qgis

• Blogs: http://plugins.qgis.org/planet/

• It is easy to install, as the installation file is around 500 MB and no 
license or internet connection is needed for the installation process.

• It is customizable. There is free access to a wide variety of plugins 
(the equivalent to extensions in ArcGIS) and tools.

• It is frequently upgraded and updated.

• In the QGIS ecosystem, it is possible to interoperate with GDAL/OGR, 
SAGA, Orfeo, GRASS or R packages.

However, the main reason that QGIS was chosen is that it is an open-
source software that is capable of performing all the mapping tasks 
included in this manual just as effectively as commercial software.

In this manual, among all the versions available in the QGIS site, the user 
will use QGIS Long Term Release (LTR) for Windows. The LTR version 
has been chosen over the latest version, because the LTR is more stable, 
while still being updated regularly across its one-year lifespan. Users 
may bear in mind that as the LTR version is gradually improved, some 
experiences may be modified.  

1.3 Hands-on structure of this 
manual
This manual has been conceived to be a compilation of exercises that 
will teach the user how to perform common mapping tasks related to 
statistical data collection activities, such as censuses and surveys.

The theoretical component within the lessons has been minimized as 
much as possible, placing the emphasis on practicing the necessary 
skills to use the software.

The chapters are structured around a series of exercises specifically 
designed to reinforce the skills the user will rely on to conduct real-life 
mapping work. This manual explains systematically the processes that 
need to be followed in order to perform each of the tasks presented. This 
approach ensures that the user will see tangible improvements in their 
skills and remain motivated.

https://docs.qgis.org/3.10/en/docs/training_manual/index.html
https://docs.qgis.org/3.10/en/docs/training_manual/index.html
https://gis.stackexchange.com/?tags=qgis 
https://gis.stackexchange.com/?tags=qgis 
http://plugins.qgis.org/planet/
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In order to use the manual, it is necessary to download and save the 
accompanying training materials. These materials are organized in folders 
that correspond to the workflow of each chapter included in the manual and 
can be found at: https://www.spc.int/DigitalLibrary/SDD/Events/QGIS%20
manual%20GLOBAL.

1.4 Conventions used in the 
manual

Text formats

Throughout the following chapters, some parts of the text have a specific 
format. This has been done to highlight the different elements of the workflow 
and make the instructions easier to follow. These formats are explained as 
follows:

This format denotes buttons in QGIS windows as well as 
navigation paths through QGIS menus (View > Panels > 
Browser).

This format identifies QGIS’s menus, panels and windows that 
appear in QGIS.

This format indicates file paths and layer names, for instance, 
5_polygon_layers/Layers/HH_EAcode_4326.shp

This format is used to highlight when the user has to input text, 
formulas or expressions.

This format signifies keyboard keys.

The use of the mouse

The "click" instructions have been simplified as much as possible to improve 
the readability of the manual. Below are the descriptions of each of the 
mouse-related functions:

WHAT THE MANUAL SAYS DESCRIPTION

Click Click with the left button

Double-click Double-click with the left button

Right-click Click with the right button

https://www.spc.int/DigitalLibrary/SDD/Events/QGIS%20manual%20GLOBAL
https://www.spc.int/DigitalLibrary/SDD/Events/QGIS%20manual%20GLOBAL
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Icons embedded in the text

The user will find icons like these  integrated within the text to help 
them find the different controls and buttons within the QGIS interface.

Panels and numeric sequences

In the manual, the user will find pictures depicting QGIS menus and 
panels. These screenshots have been included to make sure the 
instructions are clear.

Throughout the first chapters, labelled panels and windows will help 
the user navigate the controls and subsections located within various 
menus.

Note that in the pictures of menus number sequences are used, 
whereas in the text the steps are listed by letter. These numbers and 
letters both indicate the order in which the actions will be undertaken; 
however, it is important to recognize that there is not necessarily a direct 
correspondence between the two orders. In the example below, action 1 
in the picture does not correspond to step a in the text.

As users progress, it is expected that they will become more familiar 
with the software. Thus, basic processes will be explained in detail only 
in the first chapters. The user can always refer to these chapters if they 
become confused later in the manual.
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2 SOFTWARE 
INSTALLATION  
AND FIRST STEPS

In this chapter, we will learn:

• how to download and install QGIS LTR version;

• what plugins are for and how to download, install and 
manage them in our QGIS application.

2.1 Download and install QGIS 3
In the download section of the QGIS website https://www.qgis.org/en/
site/forusers/download.html, different versions of QGIS are available. 
You will find on the top of the page information about the latest versions 
available for the different platforms.

We can choose either the 32 or 64-bit versions. For 32-bit computers and 
operating systems, it is recommended that you install the 32-bit version, 
whereas for 64-bit computers and operating systems, it is possible to 
install both versions. The 64-bit version is recommended, because it 
allows better usage of system memory.

These are the steps to download and install QGIS on your computer:

a. Open your internet browser and paste this URL address https://www.
qgis.org/en/site/forusers/download.html on the navigation bar.

b. In the section containing OSGeo4W standalone install packages, go 
to the long-term release repository option and choose either the 32- 
or 64-bit option that is compatible with your computer and operating 
system. In our case, we will select the 64-bit option. The downloading 
process will start after clicking on our selected option.

https://www.qgis.org/en/site/forusers/download.html
https://www.qgis.org/en/site/forusers/download.html
https://www.qgis.org/en/site/forusers/download.html
https://www.qgis.org/en/site/forusers/download.html
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c. Once the software is downloaded, go to the location where the 

installation file has been stored in your computer and double-click 
on it.

d. The following dialogue will appear on your screen. Click on Yes.

e. In the Welcome to the QGIS dialogue, click on Next.
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f. In the License Agreement dialogue, click on I Agree.

g. In the Choose Install Location dialogue, leave the default path and 
click Next.
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h. In Choose components dialogue, leave the default components 
selected and click on Install.

i. Once the installation process is complete, click on Finish. The 
software is now installed on your computer.
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The installation process is very simple and does not require an internet 
connection; it should take no longer than 10 minutes. Once the 
installation file has been downloaded, it is just a matter of following the 
steps explained above.

A new folder named QGIS 3.10 will be created on your desktop containing 
all the shortcuts needed to access the different programs included in 
the installation package. This manual will use QGIS Desktop 3.10 LTR 
with GRASS 7

2.2 Plugins: Downloading  
and installation process
QGIS comes with a lot of built-in functionality. QGIS developers and 
people in the user community are constantly creating new plugins. The 
easiest way to access these tools is to install them through the QGIS 
Plugin Manager, included in the QGIS application. It is important to note 
that access to these tools and extensions is completely free. This is 
one of QGIS’s strengths compared to other GIS software, for which it is 
necessary to purchase additional licenses to use these specific advanced 
tools.
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How to install a new plugin in QGIS

a. Open the QGIS program.

b. In the top menu, go to Plugins > Manage and Install Plugins…

c. We want to install the autoSaver plugin that will be used later in this 
manual.

d. Make sure that in the left panel the option All is selected.

e. Type autosaver in the search bar.

f. Select the plugin from the list below.

g. Click on Install Plugin.

 

How to uninstall a plugin

a. In the top menu, go to Plugins > Manage and Install Plugins…

b. Go to Installed on the left side panel.

c. Select the plugin you want to uninstall.

d. Click on Uninstall Plugin.

e. Note that it is not possible to uninstall core plugins as they are 
built into the software.
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How to enable/disable a plugin

Having too many plugins activated in the QGIS application may cause 
the program to lag or even crash. To ensure that QGIS is responsive and 
functions smoothly, it is important to disable plugins as soon as they 
are no longer in use.

a. In the top menu, go to Plugins > Manage and Install Plugins…

b. Go to Installed on the left-hand side of the window.

c. Check/Uncheck the plugins that you want available in the QGIS 
interface.

d. Click on Close.
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2.3 Recommended plugins
Throughout this manual, we will recommend some plugins that are 
useful for censuses and surveys projects. For more information about 
available plugins for QGIS, please refer to the QGIS plugins web portal: 
https://plugins.qgis.org/

• Digitizing Tools: This plugin includes additional vector editing/
digitizing tools missing in the basic QGIS editing tool menu.

• MMQGIS: This plugin provides a variety of additional vector analysis 
tools.

• OSMDownloader: This plugin allows the user to download 
OpenStreetMap (OSM).

• Point sampling tool: This plugin collects attributes from vector or 
raster layers using a sample point layer and is very useful when 
working with household location layers.

• QGIS Cloud Plugin: Allows the user to share projects and maps online 
through http://qgiscloud.com

• QuickMapServices: Plugin used to add base maps like OSM, Bing 
Maps or Google Maps.

• SRTM Downloader: This plugin allows the user to download SRTM 
tiles from the NASA server. Note that it is first necessary to create 
an Earthdata login at https://search.earthdata.nasa.gov in order to 
access NASA’s datasets.

• autoSaver: This plugin auto saves projects and modified layers at 
specified intervals.

• To find out more about QGIS plugins, go to this link: https://docs.qgis.
org/3.4/en/docs/user_manual/plugins/plugins.html

https://plugins.qgis.org/
http://qgiscloud.com/
https://search.earthdata.nasa.gov
https://docs.qgis.org/3.4/en/docs/user_manual/plugins/plugins.html
https://docs.qgis.org/3.4/en/docs/user_manual/plugins/plugins.html
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3 FIRST STEPS  
IN QGIS

In this chapter you will learn:

• to orient yourself in the QGIS ecosystem;

• the basics about the project and layout interfaces;

• how project files function in the QGIS environment.

3.1 Load vector layers
There are three ways to add a layer into the map canvas.

1. Through the Data Source Manager

a. Open QGIS and click on  to open a new blank project.

b. Click on  to open the Data Source Manager.

c. Select Vector on the left-hand side menu.

d. Go to the Source panel and click on  to open the file explorer.

e. Browse to 3_first_steps/Layers/Lilongwe_EA_2018_4326.shp

f. Click on ADD.
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2. Through the QGIS Browser

The Browser can be found either in the Data Source Manager panel or as 
a QGIS panel located in the interface. If the Browser panel is not displayed 
by default, in the top menu, go to View > Panels > Browser.

The Browser allows the user to navigate the computer’s file system and 
manage your GIS-related files from within QGIS.

a. Go to the Browser.

b. Navigate within the folders tree to find 3_first_steps/Layers/
Lilongwe_EA_2018_4326.shp

c. Double-click on it or drag and drop the file onto the canvas.

3. Through Windows Explorer

To open a shapefile from Windows Explorer, navigate up to 3_first_steps/
Layers/ and drag and drop the .shp extension file onto the map canvas.

After following the steps explained above, Lilongwe_EA_2018_4326.
shp layer will be displayed in the Map Canvas and in the Layers panel.

IMPORTANT

Shapefile files need three 
auxiliary file extensions 
to function as a layer in 
GIS software. If these 
extensions are not together 
in the same folder, the 
layer will not display in the 
mapping canvas.

The mandatory extensions 
are .shp (stores the 
geometry), .shx (index 
position) and .dbf (standard 
database containing the 
attribute table).

The .prj extension is not 
mandatory, but including it 
is strongly recommended 
as it contains coordinate 
system information.
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3.2 Set basic style
a. To open the Layer Properties window, go to the Layers panel, right-

click on the layer and select Properties, or double-click over the layer.

 
b. On the left side of the menu, go to the Symbology section where 

parameters such as fill, and outline properties can be set.

c. It is possible to set your own style by selecting a colour for the fill and 
the outline and clicking OK.
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d. Alternatively, you can select one of the predetermined styles 
available.

e. Click Apply to preview the results.

f. Click OK to set the new style.
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3.3 Set basic labels
a. Open the Layer Properties.

b. On the left side of the menu, select Labels.

c. In the drop-down menu, replace the option No Labels with Single 
Labels.

d. In the Value drop-down menu, select the attribute that is going to 
be used to label the layer. In this case, we will select EA_CODE, the 
field that stores the enumeration area (EA) code of each EA polygon.

e. Complete to your requirements the following formatting options:

• Text: parameters related to the label’s font, style, size or colour.

• Formatting: paragraph and number formatting options.

• Buffer: parameters to add a coloured buffer around the labels to 
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improve contrast and visibility in the map.

• Background: settings to set a panel with different sizes and 
shapes behind the labels.

• Shadow: settings to display a shadow behind the labels.

• Callouts: to connect labels and features with lines.

• Placement: parameters to set the most suitable locations for 
the labels.

• Rendering: controls whether the labels are visible on the map 
or not, depending on different factors like the zoom level or the 
interaction with other features in the map.

 
f. Click Apply to preview the results on the map and, once you are 

happy with it, click OK to save the changes.
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3.4 Save/Open project
QGIS sessions are called projects. Projects allow the users to store map 
layers, overlay orders and symbologies in a specially designed file format.

By and large, the QGIS project file stores the following information:

• layers added in the canvas

• layer properties, including symbolization and styles

• projection for the map view

• last viewed extent

• print layouts

• print layout elements with settings

• print layout Atlas settings

• digitizing settings

• table relations

• project default styles

• plugins settings

• queries stored in the DB Manager.

a. To save and name the project the first time, click on , select the 
location to store it and click on the Save button.

IMPORTANT

The layers loaded in the 
project are not stored in 
the project file. The project 
"memorizes" the layers’ 
paths and retrieves them 
from their locations. This 
means that if we change the 
location of one of the layers 
or we delete it, the next time 
we open the project, the layer 
will not be added into the 
canvas as the project will not 
"know" where to find it.
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b. To save any changes to the project, click on . It is strongly 
recommended that you save your changes as often as possible. 
QGIS does not automatically save changes, which means that if 
for some reason the program crashes, you will lose all that was not 
saved previously.

c. Click on  to open a new blank project.

d. To open an existing project, click on , navigate to find the project’s 
location (.qgs extension) and click on Open.

3.5 Add a base map
3.5.1 QuickMapServices

a. Install the QuickMapServices plugin (for more information, see 
chapter 2.2).

b. In the top menu ribbon, go to Web > QuickMapServices > Settings 
> More services and click on Get contributed pack.
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c. Go to Visibility and check/uncheck the services that you want to be 
available and click on Save.

d. Then, to load a satellite image background, go to Web > 
QuickMapServices > Google > Google Satellite.
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To improve the readability of the map when using a satellite image 
background, it is recommended that styles with transparent fills are used.

a. Open Layer Properties by double-clicking on the layer.

b. Go to Symbology and click on Simple fill to modify the polygon 
style settings.

c. In Fill colour, select transparent fill.

d. In Stroke color, select a colour for the outline of the polygon that 
contrasts with the background in order to improve the visibility of 
the boundaries.

e. In Stroke width, find a compromise between the level of detail and 
the visibility of the polygon’s limits.
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f. Click Apply to preview the results on the map and, once you are 
happy with them, click OK to save the changes.
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3.5.2 XYZ Tiles

There are two ways to create XYZ Tiles connections.

1. Manual set-up

a. In the Browser panel, right-click over XYZ Tiles and select New 
Connection…

b. Under Name, add the name we want see on the Browser panel for 
this connection, such as Google Satellite.

c. In 3_first_steps/Other/Paths XYZ TILE SERVER.txt, you will find 
the URLs for a selection of Tile Map Services (TMS). Copy the URL 
under the Google Satellite heading (third URL option) from the text 
file and paste it into the URL bar.

d. Click Ok.

e. In the Browser panel, below XYZ Tiles, the connection Google 
Satellite should now be available.

f. Display the satellite image background from Google on the map 
canvas by double-clicking on Google Satellite.

g. Python script set-up1

We can set up a large number of TMS at once by using this Python script 
posted in https://raw.githubusercontent.com/klakar/QGIS_resources/
master/collections/Geosupportsystem/python/qgis_basemaps.py

The script is also available in 3_first_steps/Other/Script XYZ TILES.txt. 
Load the TMS by following these steps:

a. In the top menu, go to Plugins > Python Console.

b. In the Python Console, paste the script in the panel located at the 
bottom.

c. Click on  to run the command.

1  This chapter is based on an open.gis.lab blog post: https://opengislab.
com/blog/2018/4/15/add-basemaps-in-qgis-30

https://raw.githubusercontent.com/klakar/QGIS_resources/master/collections/Geosupportsystem/python/qgis_basemaps.py
https://raw.githubusercontent.com/klakar/QGIS_resources/master/collections/Geosupportsystem/python/qgis_basemaps.py
https://opengislab.com/blog/2018/4/15/add-basemaps-in-qgis-30
https://opengislab.com/blog/2018/4/15/add-basemaps-in-qgis-30
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d. In the Browser panel, under XYZ Tiles you will find a significant 
number of TMS available.
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3.6 How to deal with projections 
in QGIS
By default, projects in QGIS open in WGS 84 Coordinates Reference 
System (CRS), of which the EPSG code is 4326. QGIS reprojects data 
"on the fly" (it was called "OTF" in previous versions). This means than 
even if several layers have different CRS, QGIS will attempt to represent 
them in the same extent.

Check the project’s projection

a. In the bottom-right corner of the QGIS interface the CRS used by the 
project is displayed.

b. Click on to open Project Properties and go to CRS.

c. In this panel, it is possible to select the CRS that will be used by our 
project.

d. Use the search bar to find a suitable CRS for your project. In this case, 
we will search for "PDC Mercator".

e. Select the CRS with code EPSG:3832.

f. Click OK.
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Check the layer’s projection

a. Open 3_first_steps/Layers/South_Tarawa_EAs2015_4326.shp

b. Open Layer Properties to check which CRS the layer is using 
(remember, to open Layer Properties double-click on the layer’s 
name in the Layers panel).

c. Go to Information. In the Information from provider section, you will 
find the CRS used by the layer. Click OK.

Change the layer’s projection

a. Open 3_first_steps/Layers/KIR_IID_4326.shp, which corresponds 
to the island boundaries for Kiribati.

You will notice that two groups of islands are displayed on the opposite 
sides of the map. This is because the International Date Line crosses 
through the middle of Kiribati’s geographical extent. The default QGIS 
CRS, WGS 84, is centered on meridian 0, but our map needs to be centered 
on meridian 180. To solve this problem, we are going to reproject our layer 
into a new CRS.
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b. On the Layers panel, right-click on the layer’s name and go to Export 
> Save Features As…

c. In Format make sure that you select ESRI Shapefile file type. 

d. Next to File name, click on  to open the file explorer and select 
the name and location of the new layer.

e. Next to the CRS bar, click on  to open the Coordinate Reference 
System Selector.

f. In the Filter bar, type: 3832

g. Select the WGS 84 / PDC Mercator CRS in one of the panels below 
and click OK.
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h. Back on the Save Vector Layer as… panel, click on the OK button.

i. Change the project’s projection to CRS PDC Mercator EPSG:3832 by 
following the steps explained at the beginning of the chapter.

j. On the map canvas, the islands will be displayed properly, as the 
projection has been centered on the Pacific region.
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3.7 First basic enumerator map 
layout
The objective for this section is to create an enumerator map for Lilongwe 
(Malawi), for one of the Enumeration areas (e.g. EA 21053008). Before 
we start working with the map layout, we are going to prepare the map 
in a blank project.

a. Open a new QGIS session or a new project by clicking on .

b. Load 3_first_steps/Layers/Lilongwe_EA_2018_4326.shp

c. Set a transparent fill style and white buffered labels for the EA codes 
(see Sections 3.2 and 3.3).

d. Add a Google Satellite background from XYZ Tiles.

e. Save the project in 3_first_steps/ folder.

f. After following the steps above, our map should look similar to the 
image below.

3.7.1 Create a new print layout

a. To open a new layout, click on , or, in the top menu, go to Project 
> New Print Layout.

b. Give the layout a name, then click OK and the Print Layout interface 
will appear.
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3.7.2 Page properties

a. Right-click on the blank page and click on Page Properties…

 
b. Go to the Item Properties tab located in the menu on the right side 

of the screen.

c. Go to Size and select A4 from the drop-down menu.

d. Go to Orientation and select Landscape.

e. In Background, select a colour for the page background.

Throughout the following steps, do not forget to save your changes 
regularly by clicking on .
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3.7.3 Add a map

a. To add a map canvas, click on .

b. Draw a rectangle where the map will be located.

c. Using , it is possible to select the map canvas (and any other 
element created on the layout) to drag or resize it.

d. Use  to move (zoom and drag) the content inside the map canvas 
and to center the map according to your preferences.

e. On the right side of the Print Layout interface, you will find various 
menus organized in different tabs.

f. With the map canvas selected, click on Item Properties. Within this 
menu we can configure settings such as the size, the scale or the 
layers displayed in the map, among others. We will go through this 
menu in greater depth in the following chapters of the manual.

g. If you want to copy the map extent from the main QGIS interface 
to the print layout, go to the Item Properties tab, and in the Extents 
section, click on Set to map canvas extent.

h. If you want to copy the map extent from the main QGIS interface to 
the print layout, go to ITEM Properties and click on  
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3.7.4 Add a title

a. To add a new title, click on .

b. Draw a rectangle where you want the title to be located. 

c. Go to Item Properties and type your desired title in the Main 
Properties section.
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d. In Appearance, select the font type, the size, the colour and the 
alignment of the text.

3.7.5 Add a scale bar

a. Click on  to add a scale bar.

b. Draw a rectangle where you want the scale bar to be located.

c. In the Item Properties menu, it is possible to configure the settings of 
the scale bar, such as the style, the units or the number of segments.

3.7.6 Add an image

a. Click on  to add an image. In this example, we are going to add 
a generic logo next to the title.

b. Draw a rectangle where you want the image to be located.

c. Go to the Item Properties menu. In the Main Properties,  
click on .

d. Add the image saved at 3_first_steps/Images/QGIS logo.jpg and 
click Open.

3.7.7 Add a north arrow

a. Click on  to add another image.

b. Draw a rectangle where you want the north arrow to be located.

c. Go to the Item Properties menu. In the Search Directories section, 
you will find a screen displaying SVG objects including different 
models of north arrows.
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d. In the SVG Parameters section, it is possible to set the fill and the 
outline settings.

3.7.8 Add a legend

a. Click on  to add a legend.

b. Draw a rectangle where you want the legend to be located.

c. Go to the Item Properties menu. In the Legend Items section, 
uncheck Auto update to manually control the contents of the legend. 
You will notice that the controls underneath the preview panel are 
now active.

d. To delete one of the items, select it and click on .

e. Either double-click on the item or click on  to change the text of 
the item and make it more succinct.
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3.7.9 Export/Print the map

Once you are happy with the layout, which should look something like 
the following map, you are ready to export the map.

a. To directly print the map, click on .

b. To export as image, click on .

c. To export as SVG, click on .

d. To export as PDF, click on .

To learn more about layouts, go to: https://docs.qgis.org/3.4/en/docs/
user_manual/print_composer/index.html

https://docs.qgis.org/3.4/en/docs/user_manual/print_composer/index.html
https://docs.qgis.org/3.4/en/docs/user_manual/print_composer/index.html
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4 POINT LAYERS: 
HOUSEHOLD 
LOCATIONS  
(BASIC VECTOR ANALYSIS)

4.1 Import point layers from 
different data sources
Statistical sampling frames are generally often constructed from 
population or agricultural censuses. Information on the location of 
enumeration areas or of a household has become increasingly geo-
referenced in digital format. If the units are enumeration areas, the list 
of statistical units can be easy to produce. Building or updating a digital 
layer of EA boundaries may require significant investment for statistical 
institutions and ministries of agriculture. In the case of household surveys 
or agricultural surveys, this allows EAs to be defined on the basis of digital 
maps. This facilitates the construction of digital sampling frame and 
having a point layer.  

Point layers are mainly used in censuses and surveys to represent 
households (referred to from now as "HHs") or facilities like schools, 
hospitals, etc. These point locations are commonly collected using GPS 
units, tablets or smartphones, generating different file formats depending 
on the device and/or the application used."

In this chapter, we will examine how to load a point layer generated 
with either a GPS unit or a computer-assisted personal interview (CAPI) 
application into QGIS. In both cases, before starting to work with the file, 
we must determine:

• the CRS that has been used for the data collection;

• the units and the format used to express the points’ locations, making 
sure that we use ones that QGIS can "read". For instance, using WGS 
84, the CRS used in GPS, we have to ensure that the coordinates are 
expressed either in decimal degrees or in degrees/minutes/seconds 
to avoid errors when plotting the points.
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4.1.1 CAPI: Delimited text file (.csv)

This section will explain how to import and plot GPS data from a CAPI 
database. QGIS does not import tables in Excel format (.xls or .xlsx 
extensions). You will first need to save your tables into CSV (MS-DOS) 
format.

a. To load the table into QGIS, in the top menu go to Layer > Data Source 
Manager or click on .

b. On the left side of the menu, select Delimited Text.

c. Go to the File name panel and click on  to open the file explorer.

d. Open 4_point_layers/Tables/MOZ_HHlocations.csv

e. In File Format, select the CSV (comma separated values) option.

f. Under Geometry Definition, select the Point coordinates option 
and select the fields corresponding to the latitude and longitude 
coordinates in the X field and Y field panels. Make sure that the DMS 
coordinates option is unchecked as our coordinates are expressed 
on Decimal Degrees, not on Degrees Minutes and Seconds format. 
For Geometry CRS, select EPSG:4326 – WGS 84. 

g. Click on Add and then on Close.

The corresponding cloud of points will be displayed on the map canvas. 
Note that this layer is not a proper layer; QGIS is drawing the points "on the 
fly" by reading the coordinates from the table. This means that, although 
the points are displayed, it is not possible to undertake any editing, like 
generating or deleting points, for example. To resolve this, we will export 
the table into a shapefile.
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h. In the Layers panel, right-click on the "layer" and go to Export > Save 
Features As…

i. In Format, select ESRI Shapefile.

j. Click on  and select the location where the shapefile will be stored 
(4_point_layers/Layers/ is the recommended path).

k. In CRS, ensure that EPSG:4326 – WGS 84 is selected.

l. Click on OK.

m. Load a Google Maps or Satellite background to verify that the HH 
locations are displayed correctly.
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4.1.2 GPS unit (example for Garmin Etrex) (.gpx format)

Garmin Etrex 10/20/30 models can be connected via USB to your 
computer and GPS points can be imported using the .gpx format, which 
can be opened directly in QGIS.

a. To load the .gpx file, in the top menu go to Layer > Data Source 
Manager or click on .

b. On the left side of the menu, select Vector.

c. Go to the File name panel and click on  to open the file explorer.

d. Open 4_point_layers/Etrex/HHlocations_GPS.gpx

e. Click on Add.

f. In the Select Vector Layers to Add… panel select the waypoints 
option and click OK.

g. Close the Data Source Manager.

h. If the new cloud of points does not appear on the map canvas, in the 
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Layers panel right-click on the HHlocations_GPS layer and select 
Zoom to Layer.

i. Load a Google Satellite background to check that the GPS waypoints 
are displayed correctly.

Note that this layer, as in the previous example with .csv files, is not stored 
as a shapefile. This limits the operations that can be conducted within 
the QGIS environment.

j. To export this layer into shapefile format, follow the same steps as 
that for exporting .csv files into .shp, and save it in 4_point_layers/
Layers/

4.2 Edit point layers
4.2.1 Create/Delete features

a. Open a new project  and load 4_point_layers/Layers/HHFrom_
GPS_4326.shp into the map canvas.

b. Open a satellite image background. This will be useful while we edit 
the layer.

When editing a layer, it is recommended that you make a copy of it and 
modify the copy instead of the original. This way, if you make a mistake, 
like erasing geometries by accident, the original file will remain as a 
backup to recover the lost data.

c. Make a copy by exporting the layer into 4_point_layers/Layers/ and 
name the layer HHFrom_GPS_4326_EDITED.shp, for example.
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d. Remove the original shapefile from the Layers panel by right-clicking 
on the layer and selecting Remove Layer…

e. Select HHFrom_GPS_4326_EDITED in the Layers panel and click 
on  to start the editing session. You will notice that some of the 
controls of the Digitizing Toolbar are activated and that the pencil 
symbol appears next to the label in the Layers panel.

 

At this point, we want to add some plots that are hypothetically missing 
from the GPS dataset.

f. Zoom to the location where you will plot the new location.

g. Click on . You will notice that your cursor changes from 
to .

h. Place the cursor over the new point location and click.
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i. Fill at least one of the fields in the Features Attributes panel and 
click OK.

j. Repeat the process with some more points and click on  to save 
the changes.

k. To stop the editing session, click again on .

4.2.2 Move features

There are two ways to move a feature in QGIS. The first way is to use the 
Advanced Digitizing Toolbar.

a. Right-click on the top menu, and in the Toolbars section, select 
Advanced Digitizing Toolbar. This toolbar (below) will be aggregated 
to the top menu with all the controls deactivated.

b. Click on  to start the editing session. You will notice that some 
of the controls in the toolbar will be activated.

c. Click on . Your mouse cursor will change to this symbol .

d. Click on the point you would like to change, then move the cursor to 
the new location and click for a second time. The point will appear 
in its new location.

e. Click on  to save the changes.

The second method to move points uses the Vertex Tool, which is 
located in the Digitizing Toolbar.

a. Click on  and your mouse cursor will change to .

b. Move the cursor over the point you wish to move, and you will see 
that the cursor will change to .

c. Click on the point and your cursor will change to .

d. Move the point to its new position and click to place it.

e. Click on  to save the changes.

These two methods are very similar as they both use the same sequence: 
left-click + move feature + left-click.

4.2.3 Modify attribute table

In this subsection, you will keep working with the HHFrom_GPS_4326_
EDITED layer.

a. Select the layer in the Layers panel and open the Attribute Table by 
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clicking on  located in the top menu.

The other way to access the Attribute Table is by right-clicking on the 
layer in the Layers panel and selecting Open Attribute Table.

Notice that the Attribute Table contains several fields but all of them are 
empty. They are not required for this exercise, so we will remove all of 
them except the field Name.

b. To start the editing session, click on . This control can be found 
in both the main QGIS and Attribute Table windows.

c. In the Attribute Table, click on  in the menu ribbon at the top of 
the window.

d. Select the fields to delete in the Delete Fields panel and click OK.
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e. Click on  to save the changes. As a result, the Attribute Table 
now contains only the field Name.

f. With the editing session still activated, we can modify the cells in the 
Attribute Table. In this instance, we will randomly populate some 
names in the field Name to test how it works.

g. Click on  and select one of the points on the map canvas and the 
Identify Results panel will be displayed.

h. Go to Actions. If the editing session is activated, the option Edit 
feature form will be available (when the editing session is deactivated, 
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the option displayed is View feature form).

i. Click on Edit feature form, fill the fields appropriately and click 
OK. The modifications undertaken in the Edit Feature Form will 
be reflected in the Attribute Table. Then click on  to save the 
changes.
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j. Go back to the Attribute Table. Make sure that the editing session 
is activated and then click on  to create a new field (column) in 
the Attribute Table.

k. In Name, type a name for the field.

l. In Type, we will define the type of data the new field is going to store.

Whole number for data like HH size, number of rooms in the dwelling or 
questionnaire codes.

Decimal number for data that need the use of decimals like percentages 
or rates.

Text for data like names or occupancy status.

Date and Date & Time to store data like date of the interview or date of 
birth.

m. Create two fields: one for occupancy status named Occupancy and 
the other for the number of people living in the HH named HHsize. 

n. Populate some rows using Edit Feature Form and the Attribute Table 
and click on  to save the edits.

4.2.4 Join attributes by location (spatial join)

We are going to add some information to the GPS points’ attribute 
table using the enumeration areas layer. The information is going to 
be transferred from the polygon layer to the point layer using a spatial 
relationship.

a. Open a new project  and load 4_point_layers/Layers/MOZ_
HHlocations_4326.shp and 4_point_layers/Layers/MOZ_EA_
example_4326.shp into the map canvas.

b. In the Layers panel, place the point layer above the polygon layer to 
allow the visualization of both layers.
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c. In the top menu, go to Vector > Data Management Tools > Join 
Attributes by Location.

d. In Input layer, select MOZ_HHlocations_4326.shp, the point layer 
that is going to take the information from the polygon layer.

e. In Join layer, select MOZ_EA_example_4326.shp, the layer that is 
going to provide the information.

f. In Geometric predicate, select within.

g. In Fields to add, click on   and select the fields you want to add 
into the point layer and click OK.

 

h. In Joined layer, click on  and select the location for the new 
point layer and its name (4_point_layers/Layers/MOZ_HHlocations_
ADDED_DATA_4326.shp, for instance).

i. Click on Run.
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j. In the Layers panel the new point layer will appear as a Joined layer. 
Check in its Attribute Table to ensure that the new fields from MOZ_
EA_example_4326.shp have been added.
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5 POLYGON LAYERS: 
ENUMERATION  
AREAS  
(BASIC VECTOR ANALYSIS)

5.1 Create a new polygon layer: 
Digitize new features
First, we will prepare the project file so that we can undertake the exercise.

a. Open a new project  and load 5_polygon_layers/Layers/MWI_
HH_EAcode_4326.shp into the map canvas.

b. Load a satellite background underneath the point layer. This will be 
useful when delineating the enumeration area (EA) boundaries.

The HH location layer contains a field with the EA codes; this will help us 
to determine the boundaries of each EA.

c. In the Layers panel, open the Layer Properties menu and go to 
Symbology.

d. In the first top drop-down menu, select Categorized.

e. In Value, select the EA_CODE field and click on Classify. Note that 
the points are displayed using different colours depending on their 
EA code.
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f. Click OK. The map should look similar to this:

The next step is to create a layer from scratch that corresponds to the 
EA boundaries.

g. Click on , or, in the top menu, go to Layer > Create Layer > New 
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Shapefile Layer…

h. In File name, click on  to set the name and the location of the new 
shapefile (e.g. 5_polygon_layers/Layers/EnumAreas_4326.shp).

i. For Geometry type, select Polygon.

j. For the CRS, choose EPSG:4326 – WGS 84.

k. Using the New Field section, we will create a field with Name: eaid, 
Type: Whole number, and Length: 10. Then click on Add to Fields 
List.

l. Click OK and the layer will be added to the Layers panel (there will be 
no polygon displayed because the layer is still "empty").

m.Select the layer in the Layers panel and click on  to start the 
editing session.

n. Click on  to add a new polygon. The mouse cursor will turn into a
. Remember that even when you are using the Digitizing tool, you 

can zoom in and out on your map by rolling the mouse wheel, and 
you can pan around by holding down the mouse wheel and dragging 
around in the map.

o. Trace the EA boundary by clicking along the limits of the EA. Use 
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natural and artificial features to guide your demarcations.

p. Right-click to finish drawing the polygon, and the Feature Attributes 
dialog will be displayed. Fill the fields with the appropriate information 
and click OK.

q. Create more EA polygons by following the steps explained above. 
Do not forget to frequently save your changes to the layer by clicking 
on .

5.2 Snapping
The snapping tool allows the user to snap objects to each other during 
the Digitizing process. This is a time-saving tool, which also reduces the 
number of topology errors (gaps and overlaps between polygons).

Next, we will clean the topology of the layer we have just created. Given 
that we did not use the snapping tool when creating our first polygons, 
the polygon boundaries do not match to each other; therefore, the layer 
looks similar to the following image.
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a. If the Snapping Toolbar is not available in the top menu, right-click 

on the top menu ribbon and select Snapping Toolbar in the Toolbars 
section.

b. Click on  to enable/disable the snapping tool.

c. Click on  to select in which layers the snapping tool is enabled: 
All Layers, Active Layer or Advanced Configuration. Select Active 
Layer as this is the simplest option and will make learning how to 
use this tool easier.

d. Click on  to select whether the snapping tool works for Vertex, 
for Segment or for both Vertex and Segment. Select the third option: 
Vertex and Segment.

e. Use this menu  to set the Tolerance of the 
snapping tool. We can increase/decrease the tolerance using either 
pixels or map units. It is a good idea to conduct some trials to make 
sure that you have configured the tolerance to an appropriate level.
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f. Click on  to enable Topological Editing (when using this tool, 
features that share a vertex will be modified at the same time when 
you move this shared vertex). This is very useful to delineate and 
modify the boundaries between EA polygons.

g. Click on  to enable/disable the Snapping on Intersection. This 
tool allows you to snap intersections that do not have a vertex.

5.3 Editing (delineating, attributes)

Now that the snapping tool is enabled, we will clean and improve the 
existing polygons, making sure that the neighbouring polygons share 
clean and clear boundaries.

a. In the Layers panel, open the Layer Properties menu and go to 
Symbology. Click on Simple fill.

b. Reduce the Opacity to 50% to allow the satellite background to 
be visualized and set a high contrast colour for the Stroke. Being 
able to clearly see the polygons’ boundaries helps immensely when 
correcting any errors.
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c. In the Layers panel, select EnumAreas_4326.shp and start an editing 
session .

d. Click on  to activate the Vertex Tool. You will notice that the 
polygons light up in red when the cursor is above them.

e. Move a vertex: Select the vertex by clicking on it. Move the cursor 
close to a different vertex or line where the vertex will be relocated; 
the vertex will be "attracted" and will match perfectly. Click again to 
place the vertex in its new location.
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f. Create a new vertex: When hovering the cursor over the edge of 
the polygon, a suggested new node will appear in the centre of the 
segment. Click on it and fix it to the new position.

g. Delete a vertex: Select the vertex by holding Shift and clicking on it 
or by clicking and dragging a rectangle around one or more vertex. 
When the vertex is selected the colour changes to blue. To delete the 
selected vertices, press Delete.

h. Lock a feature before editing: We can lock a feature for editing by 
right-clicking on it. Once it is locked, the editing operations will be 
applied only to this polygon. This is very useful when editing several 
layers close to each other. In this type of situation, the selection 
and modification of vertices and segments can be difficult and will 
force you to work with the mouse and the zoom to accurately select 
a specific vertex.

Now we will drag/create/delete vertices to "stitch" together the boundaries 
between the EA polygons. Use the satellite image background to better 
define the boundaries using roads, streets and natural landmarks where 
possible.

i. Do not forget to save edits in the layer by clicking on .
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5.4 Split/Merge enumeration 
areas: Best management 
practices (code system, 
delineation)
In this exercise, we will analyse the EA framework and calculate the 
number of HH contained within each polygon. Then we will update the 
layer by splitting and merging polygons to meet the condition that each 
EA must contain between 120 and 150 HH.

a. Open a new QGIS session or a new project by clicking on .

b. Load 5_polygon_layers/Layers/HH_NOcode_4326.shp and MWI_
Lilongwe_EA_4326.shp layers.

c. Load a satellite image background.

To count the number of HH within each EA (the number of points within 
each polygon) we will use the Count Points in Polygon tool.

d. In the top menu, go to Vector > Analysis Tools > Count Points in 
Polygon tool.

e. In the Polygons section, select MWI_Lilongwe_EA_4326.shp

f. In the Points section, select HH_NOcode_4326.shp

g. In the Count field name, type HHnum

h. Leave the Count section blank; the tool will create a temporary layer, 
which is sufficient for our needs at the moment.

i. Click Run, and when the process is finished, Close the tool.
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j. A layer named Count will show in the Layers panel. Open its Attribute 
Table  and check that the HHnum field is displayed therein.

Using the HHnum field we are now able to assess which EA polygons 
need to be adjusted to meet the EA size conditions. The EAs containing 
more than 150 HH will be split into smaller EAs, whereas the EAs with 
less than 120 HH will be merged with other adjacent polygons.

It is also necessary to create a new field to store the new EA codes for this 
updated EA framework. Rather than creating completely new codes, we 
will add a digit to previous EA codes to indicate the EAs that have been 
split (if we expect to split one of the EAs in more than 10 parts, then we 
will need to add two digits). For instance, after splitting the EA 21048001, 
the resulting two new EAs will be coded as 210480011 and 21048001 
respectively. If EA 21055010 does not need to be split, it will be simply 
coded as 210550101.

a. Go to the Count layer’s Attribute Table  and open the Field 
Calculator by clicking on .

b. Check the option Create a new field.

c. In Output field name, type EA_2020
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d. In Output field type, select the Whole number (integer) option.

e. In Output field length, type 10

f. In the Expression panel, type "EA_CODE" || ‘1’

g. In Output preview, check that there are no error messages.

h. Click OK and check the attribute table to ensure that the field has 
been correctly generated.

  

i. In the Layers panel, right-click over the Count layer and go to Export 
> Save Features As… and save it as 5_polygon_layers/Layers/
MWI_Lilongwe_EA_2020_4326.shp

We now have all the elements to start the updating process. From this 
point onwards, all the edits (splits, merge and recoding operations) will 
be done to MWI_Lilongwe_EA_2020_4326.shp

j. To prevent unwanted changes in the original layer, MWI_Lilongwe_
EA_4326.shp, we will remove it from the Layers panel by right-
clicking on the layer and selecting Remove Layer. Do not forget to 
save the changes to your project frequently by clicking on .

Split EA polygons

a. Set the style of the layer with a transparent fill so that the satellite 
layer is visible underneath the polygon layer.

b. Toggle the editing mode  for the layer MWI_Lilongwe_
EA_2020_4326.shp
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c. Open the Attribute Table  and sort the rows by HHnum field by 
clicking on the field heading. Select an EA with more than 150 HH 
(e.g. EA 210550331 with 301 HH inside) and click on  to zoom to 
the selected polygon. The EA polygon will appear in the map canvas 
highlighted in yellow.

d. When splitting polygons, we will need to use  to select the 
polygons and  to clear the selection. Remember that before we 
start selecting the features from a layer, it is necessary to select the 
target layer in the Layers panel.

For example, for the EA 210550331, we need to divide the polygon into 
two parts in order to meet the EA size requirements (120–150 HH). At 
the same time, we must have in mind that the limits of these new EAs 
need to be easily identifiable on the ground.

e. Select HH_NOcode_4326.shp in the Layers panel and click on the 
tool Select Features by Polygon (click on the arrow next to the  
button to display the drop-down menu and click on ).

f. Delineate a polygon by clicking consecutively to surround the points 
that will be included in the new split. Then right-click to finish the 
selection process.
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g. The selected points will be highlighted in yellow. At the bottom of 
the interface, a message will appear indicating the number of points 
selected. There are 149 points selected with clear boundaries for our 
drafted polygon; this means that we can proceed with the polygon 
splitting process.

h. Select MWI_Lilongwe_EA_2020_4326.shp, make sure that the 
editing session  is activated, and click on the Split Features 
button  located in the Advanced Digitizing Toolbar. Then trace 
the line that will cut the polygon in two parts by clicking consecutively 
on the left button. Click on the right button to finish the new boundary. 
When delineating the new boundary, make sure that the start and 
the end points of the line are out of the polygon that we want to split.
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i. Now that the EA has been divided into two features, we will double-
check the number of points contained inside the new EAs. Select the 
point layer in the Layers panel, select  and right click onto the 
new polygon. Select the polygon MWI_Lilongwe_EA_2020_4326.
shp in the dialogue displayed. All the points within the polygon will be 
automatically selected. Check the number of points in the message 
located at the bottom of the interface.
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j. After splitting the polygon, you will find two identical rows in the layer’s 
attribute table. Consequently, it is necessary to assign a different EA 
code to the new EA polygon. Select the new EA polygon using 
, and find the row that corresponds to the polygon highlighted in 
blue in the Attribute Table. Assign a new code to the field EA_2020 
(2150550332).

k. Click on  to save your edits.

The process should be repeated with all the EAs with more than 150 
HH inside.

Merge EA polygons

If there are EAs containing too few HH, we can merge them with other 
existing EAs in order to meet survey-sampling conditions or to better 
manage fieldwork.

a. Open the Attribute Table  and sort the rows by HHnum field by 
clicking on the field heading. Select one of the EAs with less than 
40 HH.

We will use labels to help identify the EAs that need to be merged and 
whether or not they can be merged with those adjacent.

b. Select MWI_Lilongwe_EA_2020_4326.shp, open the Layer 
Properties panel and go to the Labels section.

c. Select the Single labels option in the first drop-down menu.

d. In the Value menu, click on  to open the Expression Dialog and 
type the following expression in the blank panel: "TA_CODE" || ‘-’ || 
"HHnum"

e. With this expression, we are creating a label that displays the village 
code and the number of HHs together.

f. An alternative method is to use the Identify features tool  and 
check one by one the information regarding each polygon.

g. Check the Output preview message that there are no errors in the 
expression and click OK.

IMPORTANT

Only EAs belonging to the 
same village/district/ward 
can be merged together. 
By following this rule the 
administrative levels’ 
hierarchy will be preserved.
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Set a visible label style in the map (big fonts and a contrasting colour) 
and click OK.  

With these labels displayed on the map, we can easily identify which EAs 
need to be merged and, among these, which ones meet the condition 
of belonging to the same village (two EA polygons belong to the same 
village when the first five digits of their EA codes are equal).

a. Make sure that the editing session is activated .

b. Use the  button and select the multiple EAs that will be merged 
into one by pressing Shift + clicking.

c. Click on the Merge Selected Features tool .

d. The Merge Features Attributes panel will be displayed. In this panel, 
we can control which values will keep the fields of the merged 
polygon.
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e. In this example, we will select one of the rows and then click on Take 
attributes from selected feature.

f. Another option is to fill the fields of the row titled Merge using the 
options located in the drop-down menus in the top row. In this 
instance, we will add the number of HH by using the option Sum in 
the HHnum field.

Once the fields are ready, click OK to complete the merging process.
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5.5 Layer styles
5.5.1 Suitable symbology when displaying administrative 

boundaries

When representing administrative boundaries, it is necessary to establish 
some basic standards in order to prepare clean and comprehensive 
maps. When we load a polygon layer into the map canvas, QGIS sets by 
default a random symbology that, in most cases, is not suitable.

It is important to prioritize an appropriate symbology if you will be working 
with a layer for a long period of time or it will be included in a map.

Fill: We tend to use pale/pastel colours and avoid bright and dark colours. 
If you are planning to use a satellite image background, you will need to 
adjust the transparency of any polygon layers to make this background 
visible beneath.

Border/Stroke: We tend to use colours that contrast with the fill colour to 
better distinguish the boundaries of the polygons. We can play with the 
width of the line to increase or decrease the limit’s visualization, keeping 
in mind that the wider the lines, the less accurate they become in the map.

Labels: Use simple fonts that are big enough to be easily read (not less 
than 6–7 points for print maps). Play with the font colours, buffers and 
backgrounds to improve the label’s visibility when layers are situated 
over dark backgrounds.

5.5.2 Manage layer styles

a. Open a new QGIS session or a new project by clicking on .

b. Load 5_polygon_layers/Layers/HH_EAcode_4326.shp and 5_
polygon_layers/Layers/MWI_EA_Pop_4326.shp layers.

c. Load a satellite image background.

We are going to set two styles: one for a map with satellite image 
background and the other for a map without it. The labels will include 
the EA code for the EA polygons and the HHid for the points.

d. In the Layers panel, right-click on HH_EAcode_4326.shp and select 
Zoom to Layer.

e. Duplicate both layers in the project by right-clicking on them in the 
Layers panel and selecting Duplicate Layer.

f. Then, rename both layers either by right-clicking and selecting 
Rename Layer or by pressing F2.
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g. For the map with the satellite image background, you should select 
a style that has a transparent or semitransparent fill with contrasting 
borders so that the satellite imagery is visible beneath. The style for 
the map without a background can be something more basic but, at 
the same time, we will try to find a colour that improves the map’s 
readability.

h. To save the style for future maps and projects, go to the Layer 
Properties panel, Symbology section, click on Save Symbol and 
type a name for the style (e.g. EA transparent). Check the Add to 
favorites option, then click on Save and then on OK. Thus, the next 
time you open the symbology menu, the symbol EA transparent will 
be available in the Favorites styles panel.
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i. A way to copy a layer’s format is by using the Copy/Paste styles tool. 
Right-click on the layer in the Layers panel and select Styles > Copy 
Style > All Style Categories.

j. Select a different polygon layer and go to Styles > Paste Style > All 
Style Categories. By selecting All Style Categories, you will transfer 
all the settings already configured in the original layer. To transfer 
only one of the categories, we will choose one of the categories 
displayed in the menu and paste it into the other layer.



QGIS FOR DIGITAL CARTOGRAPHY IN CENSUSES AND SURVEYS | POLYGON LAYERS: ENUMERATION AREAS (BASIC VECTOR ANALYSIS)  

79

5.5.3 Layers themes

The Themes tool , located at the top of the Layers panel, allows the 
user to create themes to:

• control the visibility of the layers in the map canvas;

• reference the style of each layer included in the theme;

• run some of the settings related to the legend configuration in the 
Print Layout interface.

This tool is very useful when there are different layouts and maps 
configured in one single project. This allows us to change from one 
map to another without checking/unchecking each layer one by one.

In this example, we will set two themes: one theme for a map with satellite 
background and another for a map without background.

a. In the Layers panel, select the layer with the satellite image 
background. The layer style has already been configured in the 
previous section.

b. Click on  and select the Add Theme option.

c. Add a name for the new theme (e.g. Background) and click on OK.

d. When you open the Themes menu, you will notice that the theme 
created is now available.
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e. Next, create a theme for the layers without the satellite background 
(do not forget to disable the satellite layer) and practice switching 
between themes in the map interface.

5.5.4 Categories, graduated and rule-based styles

Symbology using categories

a. Load the layer 5_polygon_layers/Layers/MWI_EA_Pop_4326.shp 
into the map canvas.

b. Open the Layer Properties panel and go to Symbology.

c. In the top drop-down menu, select Categorized.

d. In Value, chose the field that we want to use to generate the different 
categories. In this example, we want to map different districts in the 
map, so we will choose either the district code (DIST_CODE) or the 
district name (DIST_NAME).

e. Click on Classify and all the categories will be displayed in the panel 
above. It is possible to check/uncheck the villages you do not want 
to display on the map. If you double-click on a symbol, the Symbol 
Selector panel will appear, allowing you to change the colour of each 
category individually.
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f. When you have finished modifying the symbology click OK.

  

Graduated symbols

Graduated symbols can be used to generate a choropleth map (a 
thematic map where areas are shaded or coloured in proportion to 
the measurement of a continuous variable). When using a choropleth 
map, the variable MUST be standardized. The most common ways to 
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standardize data are to divide the data by the area or by the total number 
of elements in this area (in our case, people or HHs).

Before starting to use the graduated symbols, we need to standardize 
our population data using the area and afterwards create a field with the 
population density information.

We will first create the field that stores the area of each EA polygon.

a. Load again or duplicate the MWI_EA_Pop_20936.shp layer.

b. Open the Attribute Table and then open the Field Calculator .

c. Using the Field Calculator we are going to create a field that 
represents the population density.

d. In Output field name, type: area

e. In Output field type, select Decimal number (real) with field length 
= 10 and precision = 2.

f. In the Expression panel, type: $area / 1000000 (Note that, by 
default, when using WGS 84, QGIS will calculate the areas on square 
meters; we divide by 1,000,000 to convert the area units into square 
kilometers, which is a more standard unit to measure population 
density.)

g. Click OK and check that the field has been correctly created in the 
Attribute Table.

Then we calculate the population density by dividing the population by 
the area.

h. In Output field name, type: pop_dens

i. In Output field type, select Decimal number (real) with field length 
= 10 and precision = 2.

j. In the Expression panel, type: "TOT_POP" / "area"

k. Click OK and check that the field has been correctly created in the 
Attribute Table.
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Now that we have the population density field, we can start designing 
our choropleth map.

l.Open the Layer Properties panel and go to the Symbology section.

m.In the top drop-down menu, select the Graduated option.

n. In the Column section, select the pop_dens field.

o. Click on the arrow located at the right of the Color ramp to open the 
drop-down menu.

p. Select one of the proposed colour ramps.
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q. In Mode, select the Quantile (Equal Count) method to classify the 
data.

r. In Classes, choose 5 and click Classify.

s. Click OK.
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Population densities are best represented by green, orange or brown 
colour ramps. In general, it is best to use colours that have clearly 
distinguishable shades. In the image below we can see some of 
the palettes proposed at the COLORBREWER 2.0 website (http://
colorbrewer2.org).

Colour brewer palettes are available in QGIS.

a. Go to the Layer Properties panel and select Symbology, then click 
on the arrow located to the right of the Color ramp to open the drop-
down menu.

b. In the drop-down menu, select Create New Color Ramp… ,choose 
the Catalog: ColorBrewer option and click on OK.

A specific menu to configure the colour ramp using colour brewer 
schemes will appear after clicking on OK.

http://colorbrewer2.org
http://colorbrewer2.org
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Rule-based symbols

In QGIS, it is possible to set rules to control a layer’s symbology. For this 
example, we will set different symbols for EAs where there are more 
males than females and vice versa.

a. Reload or duplicate the MWI_EA_Pop_20936.shp layer.

b. Open the Layer Properties panel and go to the Symbology section.

c. In the top drop-down menu, select the Rule-based option.

d. Click on  to add the first rule and the Edit Rule panel will appear.

e. In Label, type: male or the name you want for this category.

f. In Filter, click on , type the following expression "MALE">"FEMALE" 
in the Expression panel and click OK.

g. Click on Test to check whether the expression works or not. Select 
a colour for the symbol and click OK.
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h. Click on  to add the second rule.

i. In Label, type: female

j. Check the Else option. This will catch all the EAs not included in the 
previous rules. In this case, this rule will bear on the EAs with fewer 
numbers of males than females.

k. Click OK and check the results on the map interface.
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5.6 Advanced labelling
In this section, you will learn some ways to improve your labelling skills, 
which will help you to improve the quality and visibility of the information 
displayed.

5.6.1 Custom labelling placement

a. Open a new QGIS session or a new project by clicking on .

b. Load 5_polygon_layers/Layers/CHL_Datos_Censo_2017_
Provincia_4326.shp and 5_polygon_layers/Layers/SAmerica_
bkground_4326.shp

c. Select CHL_Datos_Censo_2017_Provincia_4326.shp, open the 
Layer Properties panel and go to the Labels section. Generate labels 
using the NOM_PROVIN field and set a proper format to improve the 
readability of the layers.
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Note that in the image above that there are several labels missing. If there 
are a significant number of labels in the displayed area, QGIS "hides" by 
default the labels that overlap with others.

d. To change this, under Labels, select the Rendering submenu and 
check the option Show all labels for this layer.
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To solve the problem with label placement we will use the labelling engine 
that comes built in inside QGIS 3.4 LTR. Among other functions, this tool 
allows the user to modify each label as an independent entity and set 
the position of each label manually, which is very useful when producing 
layouts with large amounts of labels.

e. If this toolbar  is not visible in the 
top menu, right-click on the top menu, and in the Toolbars section, 
select Labels Toolbar.

f. Click on  to open the Layer Styling menu.

g. To show/hide labels, select . Hide the label by pressing Shift + 
clicking. To show the label again, click over the feature.

h. To change the location of the labels, select , then click and hold 
over one of the labels and drag it to its new position.

i. To rotate labels, select , then click and hold over the label to 
change its orientation.

j. To change the format of an individual label, select , then click 
over the label you want to modify. A menu will appear allowing you 
to change the settings, such as the font and the buffer.
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We are still able to modify settings from the Labels menu in Layer 
Properties. It is important to keep in mind that once we have activated 
a tool from the Labels Toolbar, the Labels Toolbar will exclusively control 
the label settings replacing the Labels menu. However, it is possible to 
return control to the labels menu. For example, to be able to again modify 
the size setting from the Labels menu, click on  and then select 
Deactivate. The control will change to . From now on, the parameter 
is controlled exclusively from the menu.

5.6.2 Complete layer symbology with labels

In this exercise, we will use labels to add additional information to 
our map. For example, we will display the population figures for each 
council area in the labels thanks to QGIS’s simple expression language 
commands.

a. Load 5_polygon_layers/Layers/CHL_Datos_Censo_2017_
Region_4326.shp and 5_polygon_layers/Layers/SAmerica_
bkground_4326.shp

b. Open the Layer Properties panel and go to Labels. Select the Single 
Labels option and click on .

c. Insert the following expression: "NOM_REGION" ||’ (Tpop: ‘|| 
(format_number( "TOTAL_PERS",0))||’)’ 

d. Modify the settings (font size, buffer) to improve the readability of 
the layers.
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Using an expression, we will now add values to the labels without needing 
to create new fields.

e. By entering the following expression  "NOM_REGION" ||’ (Sex ratio: 
‘||(format_number(("HOMBRES"/ "MUJERES" *100),1)) || ‘%)’ the 
sex ratio for each council area will be added to the label.
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Note that we could have created a new field on the attribute table using 
(format_number(("HOMBRES"/ "MUJERES" *100),1)) and this new field 
could have been used to control the content of the layers. However, the 
method shown above is faster and more flexible.

We can also use expressions to control the colour of the labels.

f. In the Labels section, go to the Text subsection and at the right side 
of the Color control, click on  and select Edit.

g. An Expression String Builder panel will show. Enter the following 
expression:
case when ( "HOMBRES" > "MUJERES" ) then color_rgb(0,0,255) 
else color_rgb(255,0,0)end 

You can now see on the map that the labels’ colours are controlled 
according to whether the sex ratio is greater or less than 100%.
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As an alternative to the expressions method, we could use the rule-based 
labelling option. We still need to use expressions but they are simpler.

a. Load 5_polygon_layers/Layers/CHL_Datos_Censo_2017_
Region_4326.shp

b. Open the Layer Properties panel and go to the Labels section. Select 
Rule-based labeling and click on  to add a new rule.

c. In Filter, add the following expression for the cases where the 
number of males is greater than the number of females: "HOMBRES" 
> "MUJERES"

d. Under Value, we will still use the same expression to generate the 
compound labels: 

e. "NOM_REGION" ||’ (Sex ratio: ‘||(format_number(("HOMBRES"/ 
"MUJERES" *100),1)) || ‘%)’ 

f. Set the Color (dark grey, for instance), the Buffer and all other 
settings to improve readability.
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g. Add a new rule .

h. In Filter, insert the following expression: "HOMBRES" < "MUJERES"

i. An alternative option is to check the option Else.

j. Use the same expression for the labels at Value.

k. Set the colour (orange), buffer and all other settings to improve 
readability.

 



QGIS FOR DIGITAL CARTOGRAPHY IN CENSUSES AND SURVEYS | POLYGON LAYERS: ENUMERATION  AREAS  (ADVANCED VECTOR ANALYSIS)

96

6 POLYGON LAYERS: 
ENUMERATION  
AREAS  
(ADVANCED VECTOR ANALYSIS)

6.1 Topology cleaning: Finding 
and fixing gaps, geometric errors 
and overlaps
QGIS has a collection of snapping/intersection tools that are useful for 
creating new features while avoiding topological errors. For layers that 
already contain errors, there is a plugin that simplifies the tedious task 
of finding the often very small overlaps, gaps, etc., and repairing them.

a. Open a new QGIS session or a new project by clicking on .

b. Load 6_polygon_layers_advanced/layers/EAs_toclean_3460.shp. 
It is recommended that you create a copy of the file and edit the copy 
rather than the original. We will save the original as a backup in case 
of any irreparable mistakes.

c. Go to Plugins > Manage and Install Plugins and make sure that the 
Topology Checker plugin is installed and enabled.

d. Open the Topology Checker panel either by going to Vector > 
Topology Checker or by clicking on  in the top menu. A panel, 
like the one below, will open in the interface.
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e. Click on Configure  and the Topology Rule Settings will appear.

f. In the first drop-down menu, select the layer for which we are going 
to check the topology; in this example, EAs_toclean_3460.shp

g. In the next drop-down menu, select must not have gaps (this finds 
any gap errors contained in the layer). Next, click on  
and the new rule will be added to the panel located below.

h. Repeat the same operation for must not have invalid geometries 
and must not overlap rules and click OK.

Click on  to validate all the rules applied to the layer. A list containing 
all the topology errors will be shown.

Check the Show Errors option located at the bottom-left corner of the 
menu to highlight the errors on the map.
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Before we start fixing the various errors, we need to first activate the 
editing session .

Check that the Snapping tool  is enabled and the Topological editing 
option  deactivated.

Make sure that the reference system used in the project is the same as 
that used for the layer to ensure that the program zooms to the right 
place when selecting the errors to be corrected.

Fixing gaps

When working with administrative boundaries, all polygons must form 
a continuous surface without gaps inside or between polygons. It is 
important to remember that two polygons with coincident boundaries 
have to maintain a NODE-TO-NODE connection. This means that if you 
snap a node to an adjoining polygon’s side, unconnected to the pre-
existing nodes, this will generate a gap error, even though there is not a 
void between the two polygons.

a. In the Topology Checker panel, click on one of the gaps errors and 
the map will zoom over it. Uncheck the Show errors option to improve 
the visibility of the gap.

b. Activate the Vertex Tool , click on the vertex and drag it to align 
with the opposite vertex.
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c. In case you need to create or delete a vertex to fix a topology error 
you need to follow these steps. Create a vertex: When hovering 
with the cursor over the boundary of the polygon, a virtual new node 
appears in the center of the segment. Click on it and move it to the 
desired position.

Delete a vertex: Select the vertex by pressing Shift + clicking on it or 
by clicking and dragging a rectangle around one or more vertices. 
When a vertex is selected, the colour will change to blue. To delete 
the selected vertices, press Delete.

d. Click on Validate Extent  to ensure that the gap error has been 
corrected in the zone we are currently working. If the topology 
problems are fixed, no errors will show in the Topology Checker 
panel. Click again on the Validate All button  and correct a few 
more gaps to clearly understand this process.

e. Click on  to save the edits.

Fixing invalid geometries

If an invalid geometry error is detected, it means that the polygon 
structure is incorrect.

a. In the Topology Checker panel, click one of the Invalid Geometries 
errors to zoom to it.

The easiest invalid geometries errors are the ones generated by two or 
more overlapping vertices.

b. Use the Vertex Tool  and lock the polygon by right-clicking on it. 
The overlapping vertices are easy to spot, as they appear highlighted 
with a green cross. To fix these types of errors it is necessary to 
delete or separate the overlapping vertex.
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In other cases, the polygon is totally compressed, generating a line.

Fixing overlaps

a. In the Topology Checker panel, click one of the overlaps errors to 
zoom to it. Notice that the entire polygon containing the error is 
highlighted in green.

The problem we face here is that we do not know the precise location of 
the overlap. In most cases, finding this overlap is a tedious process that 
can be accelerated by using the built-in Geometry checking tool. 

b. Deactivate the editing session  for the EAs_toclean_3460 layer.
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c. Go to Vector > Check Geometries… to open the Check Geometries 
panel. (If Check Geometries… is not available in the menu, go to 
Plugins > Manage and Install Plugins… to enable the plugin. Chapter 
2.2 explains how to Enable/Disable plugins)

d. Select the Setup tab to configure the checks that will be undertaken 
by the tool.

e. In Input vector layers make sure that the layer EAs_toclean_3460 
is selected.

f. In Allowed geometry types check Polygon and Multipolygon 
options.

g. Given that our main objective is to accurately locate the overlaps, 
we will uncheck all the options enabled by default in the Geometry 
validity, Geometry properties and Geometry conditions sections.

h. In Topology checks select Check for overlaps smaller than (map 
units sqr.) and leave the default value 0.0000

i. In Output vector layers check the Create new layers and select the 
format and location for the new layer.

j. Click on Run to start the checking process. 
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k. The Result tab will be automatically opened and will display all the 
overlap errors in the table at the Geometry check result section.

l. In When a row is selected, move to canvas to section, make sure 
that the options Error and Highlight contour of selected features 
are checked.

As a result of the checking process, a new layer named overlapsEAs_
toclean_3460 will be added in the layers panel.

m.Put this new layer below EAs_toclean_3460. We will use 
overlapsEAs_toclean_3460 to locate the errors but we will still be 
editing and fixing EAs_toclean_3460. 

n. Activate the editing session  for the EAs_toclean_3460 layer.
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o. Then in the Check Geometries panel, click on one of rows in the table. 
The map will zoom to the exact position where the overlap error is 
located, highlighting it in yellow, and surrounding it with a red circle.

p. Using the Vertex Tool, drag, create and delete nodes to align the 
boundaries, ensuring that there are no missing or unshared vertices 
along the boundary. This is one of the main reasons why overlap 
errors occur.

q. It is recommended that you first clean all the gaps before starting 
with the overlap errors, as many gap and overlap errors are closely 
related at the boundaries between polygons.

r. Do not forget to save your edits regularly by clicking on .

Prior to working with a polygon layer, it is recommended that you check 
and fix the topology. Topology errors can cause a variety of problems 
when undertaking more complex operations with the layers.

6.2 Table join
In this section, we will import external data from a table and connect it 
to a shapefile. First, we will load the shapefile of the ward boundaries of 
Solomon Islands.

a. Open a new QGIS session or a new project by clicking on .

b. Load 6_polygon_layers_advanced/layers/Sol_Ward_4326.shp

c. Open the Attribute table  and check the available information, 
including codes and names for the wards and the provinces.



QGIS FOR DIGITAL CARTOGRAPHY IN CENSUSES AND SURVEYS | POLYGON LAYERS: ENUMERATION AREAS (ADVANCED VECTOR ANALYSIS)  

104

When importing tables into QGIS, it is important to bear in mind that QGIS 
cannot read .xls or .xlsx files. Thus it is necessary to save all tables in 
Excel in CSV (MS-DOS) format. The table we will import contains water 
and sanitation data from the 2009 census at ward level.

d. Go to Layer > Data Source Manager or click on .

e. Go to the Delimited Text section.

f. In File Name, select 6_polygon_layers_advanced/tables/solomon_
data.csv

g. In File Format, check the CSV (comma separated values) option.

h. In Geometry Definition, check the No geometry option.

i. Check the Sample Data to ensure that the preview of the data looks 
good and click Add. The table will be displayed in the Layers panel.

Now we are going to import the external table into the attribute table of 
the shapefile and add new fields to our layer.

j. Open Sol_Ward_4326.shp. From the Layer Properties panel, go to 
the Joins section.

k. Click on  to open the Add Vector Join menu.

l. In Join layer, select solomon_data

m.In Join field, select Code

n. In Target field, select WID

o. In Joined Fields, select the fields that you want to transfer from the 
solomon_data table to the layer’s attribute table. In this instance, we 
will select all the fields except Code and Ward as they are already 
included in the layer.

p. Remove all the text that appears by default in Custom Field Name 
Prefix.
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q. Click OK and check in the Attribute Table if the new fields have been 
added.

Note that for the moment these fields are temporary. To store the fields 
permanently within the layer’s attribute table, we need to save the layer 
with the attached table as a new shapefile.

r. Right-click on the layer and select Export > Save Features As…

s. Enter the name and the location of the new layer and click OK. We 
will call this layer Sol_ward_censusdata.shp
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6.3 Field calculator:  
Basic expressions
In this section, we will use the field calculator to manipulate data imported 
from tables and prepare fields with water and sanitation indicators that 
can be mapped using choropleths (this symbology must be used with 
rates or percentages).

a. Load 6_polygon_layers_advanced/layers/Sol_Ward_
CensusDatatest_4326.shp

Using the imported fields, we are going to create the following water, 
sanitation and hygiene (WASH) indicators: percentage of HHs with 
access to safe drinking water sources and percentage of HHs with 
access to safe toilet facilities. For these examples, we will consider piped 
and tank water as safe drinking water sources. Flush and water sealed 
will be considered as safe toilet facilities. This is a GIS practice exercise 
and we are aware that WASH technical considerations are much more 
complex when classifying water and sanitation sources and facilities as 
safe/unsafe. Therefore, the results from this exercise should not be taken 
into account as a contrasted analysis.

b. Open the Attribute Table and click on  to open the Field 
Calculator.

c. Check the option Create a new field.

d. In Output field name, type: safe_water

e. In Output field type, select Decimal Number (real).

f. In Output field length, set 3, and for Precision, set 2 (we are working 
with percentages like 20.25% or 100.00%; therefore, we do not expect 
longer strings).

g. In the Expression panel, type the following formula:  
(to_int( "piped_w" ) + to_int( "tank_w" ) )/ to_int( "tot_HH" ) * 100

Note that in the formula to calculate the percentage ( "piped_w" + "tank_w" 
/ "tot_HH" * 100 ) we have to add the to_int (transform to integer) operator 
because the fields are in string format (chain of characters). When using 
string format fields, the + operator concatenates the characters (52 + 83 
= 5283) rather than calculating the mathematical operation (52 + 83 = 
135), which is the result that we are looking for.

h. To generate the field safe_toile , follow the same steps but use the 
following formula:
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(to_int( "flush_t" ) + to_int( "wtrseal_t" ) )/ to_int( "tot_HH" ) *100

i. Do not forget to save any edits to the shapefile by clicking on .

These calculations could have been carried out in Excel, then importing 
the table into QGIS and linking it to the shapefile. There is no single way 
to solve problems in GIS; each user will find their own way to complete 
tasks. The idea of this exercise is to show that we can generate new 
information in the Attribute Table.

Now, try to map the safe_water and the safe_toile indicators using 
a graduated symbology based on what you have learned in previous 
chapters. These types of maps are very useful for planners and decision-
makers when targeting zones where it is necessary to improve WASH 
conditions and facilities.

6.4 Work with attribute tables
In the previous chapters, we learned how to select features using spatial 
conditions (e.g. points within polygons). Using the Attribute Table, we 
can use logical expressions to filter and select data within each field, as 
if we were using a spreadsheet.

In the following, we show some examples of using the selection and the 
filter tools from the Attribute Table.
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a. Load 6_polygon_layers_advanced/layers/Sol_ward_Data.shp

b. Open the Attribute table of the Sol_ward_Data.shp. Note that the 
field tot_HH is now in integer format (we can easily identify that 
because the figures are aligned on the right or checking that in the 
Source Fields section in the Layer Properties panel).

c. Click on each line to select a feature and the row will be highlighted in 
blue. At the same time at the top of the panel we will see a message 
stating the number of features that are selected and/or filtered.

d. By holding CTRL + clicking we can add items to the current selection 
one by one.

e. By holding SHIFT + clicking we can extend the selection up to the 
last item of our selection.
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f. Click on  to unselect all the selected features.

g. Click on  to invert the selection.

h. To select all the features, you can either click on the top-left corner 
of the table or on .

i. To visualize the selected feature in the map, click on  and the 
map canvas will zoom to the selected item.

Click on  to open the Select by Expression panel. In Expression, 
type the following basic expression:
"PName" = ‘Choiseul’

Then click on Select features, and then click on Close.

j. Click on  to zoom on the map the result of our selection. We have 
selected all the wards belonging to Choiseul Province.

k. If we want to add to this selection the wards from Guadalcanal, we 
will go to the Select by Expression panel .

l. Type the following expression: "PName" = ‘Guadalcanal’

m.Click on the arrow next to the Select features button and select the 
Add to current selection option.
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The selection will be added to the previous one.

Now we are going to select the wards where the percentage of HH 
accessing safe toilets is less than 50% and where the number of HH is 
greater than 1000. To do this, we can use two methods. First, you can use 
the Select by Expression panel  and type the following expression: 
"safe_toile" < 50 and "tot_HH" >1000    

Nevertheless, if you do not feel comfortable with expressions, you can 
use the Select/Filter Features using form tool.

a. Open the Attribute table and click on  to open the menu.

b. In tot_HH field, type 1000 and select the option Greater than (>) 
using the control located on the right.

c. In safe_toile field, type 50 and select the option Less than (<).

d. Click on Select features and check on the map and in the table which 
wards have been highlighted.
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6.5 Dissolve
In this chapter, we will create the province layer from the wards layer.

a. Load 6_polygon_layers_advanced/layers/Sol_Ward_4326.shp

b. In the top menu, go to Vector > Geoprocessing Tools > Dissolve and 
a menu will appear.

c. In Input layer, select Sol_Ward_4326.shp

d. In Dissolve field, click on  and select pid (the provinces code).

e. In Dissolved, select the location and the name of the new layer (e.g. 
Sol_prov.shp).

The province layer will be displayed in the mapping interface. If you check 
the attribute table, you will see that there are 10 features that represent 
the provinces. Because of the hierarchical relationship between the 
different levels in the attribute table of the lowest administrative level 
layer, it is possible to generate the upper levels using the dissolve tool.

6.6 Creating buffers
In this chapter, we will learn how to generate a 1 km coastal strip that 
includes the areas of the country that are located at less than 1 km from 
the sea.

a. Open a new QGIS session or a new project by clicking on .

b. Load 6_polygon_layers_advanced/layers/DMA_Land_4326.shp 

c. On the top menu, go to Vector > Geoprocessing Tools > Buffer and 
the menu of the tool will be displayed.

d. In Input layer, select DMA_Land_4326.shp

e. In Distance, note that the units must be entered in degrees. In regions 
close to the equator, a degree is approximately 111 km. To roughly 
set a 1 km distance buffer, you should enter 0.01

f. The Segments parameter controls the number of line segments 
generated to create a quarter of a circle when rendering the buffer. 
The higher the value, the more accurately drawn the resulting buffer 
object is. In our case, we will enter 20 segments.

g. In Buffered, leave the default value to generate a temporary layer 
and click on Run.
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h. If you do not see the above buffer area, try to sort the layers in 
the Layers panel to ensure that the Buffered layer is below DMA_
Land_4326.shp
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What we have in fact created is a surface that extends the polygon’s area 
1 km towards the sea. What we were intending to do is to generate a 1 
km strip inland. To achieve this, follow the steps below. While there are 
faster ways to do this task, this workflow will allow you to engage more 
with the basic processing tools available in QGIS.

Convert polygons to lines

This algorithm takes a polygon layer and creates a line layer.

First, we need to convert the polygon layer into a line. This is because 
when applying the buffer tool to a line layer, the buffer is generated at 
both sides of the line.

a. On the top menu, go to Vector > Geometry Tools > Polygons to 
Lines…

b. In Input layer, select DMA_Land_4326.shp

c. In Lines, leave the default value to generate a temporary layer and 
click on Run.

 

Generate the 1 km buffer around the line layer

a. In the top menu, go to Vector > Geoprocessing Tools > Buffer and 
a menu will be displayed.

b. In Input layer, select Lines
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c. In Distance, enter 0.01

d. In Segments, enter 20 segments.

e. In Buffered, leave the default value to generate a temporary layer 
and click on Run. (Note that this process may take a few minutes.)

Extract the part of the buffer

In this step, we are going to remove the ocean-side section of the buffer. 
To undertake this operation, we are going to CLIP the current buffer zone 
with the DMA_Land_4326.shp layer.

a. On the top menu, go to Vector > Geoprocessing Tools > Clip… and 
the menu of the tool will be displayed.

b. In Input layer, select the buffer generated from the line shapefile in 
the previous step.

c. In Overlay Layer, select DMA_Land_4326.shp 

d. In Clipped, select the name and the file of the 1 km coastal buffer 
(e.g. 1kmBuffer_4326.shp).



QGIS FOR DIGITAL CARTOGRAPHY IN CENSUSES AND SURVEYS | POLYGON LAYERS: ENUMERATION AREAS (ADVANCED VECTOR ANALYSIS)  

115

 

e. Click on Run and check the map canvas for a result similar to the 
layer represented in green in the image below.
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6.7 Find closest features to 
households – schools
In this section, you will learn how to conduct a point-to-point distance 
analysis. We are going to calculate the distance from each HH location 
(these locations have been randomly created) to the nearest school in 
Gaza Province (Mozambique). The resulting layer will help us to assess 
the accessibility to schools in this province.

a. Click on  to open a new blank project.

b. Load 6_polygon_layers_advanced/layers/MOZ_GazaProv_4326 
shp, 6_polygon_layers_advanced/layers/Roads_Gaza_4326.shp,  
6_polygon_layers_advanced/layers/Households_4326.shp and 
6_polygon_layers_advanced/layers/Schools_4326.shp

c. Sort the layers in the Layers panel to ensure that both HHs and 
schools are displayed over the provinces and roads layers.

d. In the top menu, go to Processing > Toolbox to open the Processing 
Toolbox panel.

e. In the search bar located at the top of the Processing Toolbox panel, 
type hub distance and the matching tools will be filtered among the 
available options.

f. Click on Distance to Nearest Hub (Points).

g. In Source points layer, select Households layer.

h. In Destination hubs layer, select Schools layer.

i. In Hub layer name attribute, select OBJECTID field.

j. In Measurement unit, select Meters.

k. In Hub distance, enter the location and the name for the new layer 
(e.g. HH_Dist2School).

l. Click Run and Close once the operation is completed. (Note that this 
process may take a few minutes.)
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The tool has generated a copy of the HH layer while adding a new field 
that contains the distance to the closest school. Now, playing with the 
symbology, we can highlight the different regions depending on the 
geographic access to school.

a. Select the HH_Dist2School layer (it will be probably named as Hub 
distance) in the Layers panel, then open the Layer Properties panel 
and go to Symbology.

b. In the top drop-down menu, select the Graduated option.

c. In Value, select the HubDist field.

d. In Color ramp, select the option you think is the most suitable. In our 
example, we have selected the Spectral option.

e. In Mode, select Equal interval and click on Classify.

You will notice that the furthest distances are represented in blue and 
the closest in red, but we want the opposite.

f. Right-click over the color ramp button and select Invert Color Ramp. 
Now the symbology is more logical.

To better represent the data, we need to "clean" the classification ranges 
and the legend to make them more accessible. It is always easier to read 
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and remember a value like 5 km rather than a value like 4.82 km.

g. Double-click on each of the Values and Legends to modify the class 
bounds and the values that will be displayed in the legend. Then 
click Ok.

 

h. Use a special symbol for the schools to better differentiate them 
from the HHs.

i. Click Ok and check the result on the map canvas.
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7 AUTOMATED MAP 
PRODUCTION

The Atlas is the automatic map production tool for QGIS. This feature is 
essential when producing a large number of similar maps, as is the case 
when producing enumerator field maps.

In this chapter, you will start with a preconfigured project named Atlas.
qgz where the basic format is already set in order to not repeat topics 
that have been covered in previous chapters.

Given the complexity of the chapter, a project named AtlasResult.
qgz has been placed in the training materials folder to guide you if you 
have any difficulties. The project contains all the layout results for the 
exercises presented in this chapter.

7.1 Layout and Atlas basic 
configuration

a. Click on  to open the project 7_automated_map/Atlas.qgz. Note 
that a HH locations and an EA framework layer have been loaded 
into the mapping canvas.

b. Check that EA_atlas_4326.shp, HH_atlas_4326.shp and a satellite 
image background have been loaded into the canvas. If not, load the 
layers from the 7_automated_map/Layers folder and a background 
from the XYZ tiles map service located in the Browser panel.

The atlas needs a coverage layer, which controls the map production. 
As we want to produce a map for each of the EAs, the coverage layer 
will be EA_atlas_4326.shp. This means that the atlas will "take a photo" 
of each EA and produce the maps automatically. Through the attribute 
table of the coverage layer, you can automatically add titles, filter which 
maps are to be printed and assign filenames.

c. In the top ribbon, go to Project > Layouts and open the Atlas_
landscape layout. The Layout interface will be displayed with a basic 
layout configuration, including a map canvas and a title.
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d. The Atlas menu should appear on the right side of the interface 
where the different layout menus are located. If it does not appear 
automatically, you can either click on  or go to Atlas > Atlas 
settings.

e. In the Atlas menu, check Generate an atlas.

f. In Coverage layer, select EA_atlas_4326, as this is the layer that 
contains the polygons that we want to map.

g. Do not check the option Hidden coverage layer, as we need to display 
the EA boundaries on the maps.

h. In Page name, select the eaid field to assign page names using the 
EA codes.

i. Leave the Filter with option unchecked for the moment.

j. Check the Sort by option and select the eaid field to sort the maps 
using the EA code.

k. Uncheck Single file export when possible, click on , delete the 
default expression and enter the following: "eaid"

This setting will automatically assign the EA code as the filename 
when the atlas is exported into image format. The values used to name 
the maps must all be unique from one another, otherwise maps with 
duplicated filenames will be overridden during the export process.

l. In Image export format, select the desired format for the exported 
maps. Jpg, .jpeg and .png are the most common.
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m.In the canvas, select the map and go to the Item Properties menu. 
Scroll down to find the Controlled by Atlas option and check it.

n. Select Margin around feature and set 10%

 

o. Go to the top menu and click on  to enable the Atlas Toolbar. 
Use the buttons to navigate through the different 
maps. By using the pages display , we can go directly 
to the different EAs, as we have already configured the Page name 
parameters in this way.

p. Make sure that you regularly save any changes to the project by 
clicking on .

By using this basic atlas configuration, we ensure that as the atlas 
navigates across the EA framework it will make a map of each of the 
enumeration areas. At this stage, we need to improve the layout in order 
to provide more information regarding the area that is being mapped, 
such as the EA code, the island name and the scale. The atlas feature can 
dynamically change the different titles by making use of the coverage 
layer’s attribute table.

Automatic titles

a. Go to the Layout Interface and click on . Draw the rectangle 
where you want the title to be located.

b. Make sure that the title frame is selected in the layout canvas and 
go to the Item Properties menu.

c. In Main Properties, click on Insert an Expression and enter the 
following expression:

‘EA Code: ‘||"eaid"

d. Set the text font by changing the colour, making it bold and increasing 
the size to make the title more visible.

e. Cycle through the maps by using  to check that the EA code 
matches with the EA represented on the map.

f. Insert automatic titles for the island and village names by adding 
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a new text box and using the following expression: ‘Village name: ‘|| 
"v_name" ||’ / Island name: ‘||"i_name"

Remember that in the language for QGIS expressions, the || symbol is used 
to concatenate text or variables. Single quotes ‘ are used to indicate text and 
double quotes " indicate fields from the attribute table.

Automatic scale bar

g. Go to the Layout Interface and click on . Draw the rectangle where 
you want the title to be located.

h. Go to the Item Properties menu and unfold the Units submenu.

i. In Scalebar Units, select the Kilometers option, and in the Label for 
Units, type km

j. As our scale bar is dynamic, to ensure that the item does not exceed the 
frame, select the Fit segment width option and set the size between 50 
and 100 mm.

k. Then go to Position and Size and set 100 mm for the Width of the frame.

l.  Use  to check that the dynamic scale bar is working.

m.Make sure that you save the changes to the project regularly by clicking 
on . We will keep working on the same project and layout in the next 
section.

7.2 Rule-based styles interacting 
with Atlas (Atlas variables)
In this section, we are going to set styles for both the EA and the HH layers, 
which will sync with the Atlas to improve the readability of the maps.

Style for the polygon layer

a. Go back to the main QGIS interface and open EA_atlas_4326. From the 
Layer Properties panel, go to Symbology.

b. Select the Ruled-based option in the top drop-down menu.

c. Double-click on the rule that is currently displayed, or select it and click 
on  to open the Edit Rule panel.

d. In Label, type: Selected EA

e. In Filter, click on  and enter the following expression:
@atlas_featureid = $id
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f. Then click OK.

g. Click on TEST to check that the formula is working properly.

h. Next, set a transparent fill with an orange border style and click OK.

i. Click on  to add a new rule

j. In Label, type: Not selected EA

k. Check the option Else.

l. Set the style with the same type of orange Stroke.

m.For the Fill, select a shade of blue and set the Opacity at 50%.

n. Click OK in the following three menus to save the changes and check 
that the conditional formatting has synced with the Atlas_landscape 
layout. The selected EA should appear with a transparent fill format 
and the non-selected EAs with a semitransparent blue fill.

Next, we need to modify the EA labels so that only the non-selected EA 
labels are shown on the map. We do not need to show the selected EA 
label as it will be displayed in the title. Moreover, we avoid labelling the 
selected polygon so as to prevent the label blocking the features inside 
the polygon, such as HH locations or other labels.

a. Return to the main interface and open EA_atlas_4326. From the 
Layer Properties panel, go to Labels.

b. Select the Rule-based labelling option and click on  to add a 
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new rule. The Edit Rule panel will then be displayed.

c. In Filter, click on  and enter the following expression: @atlas_
featureid <> $id and then click OK.

d. Click on Test to check that the formula is working properly.

e. In Value, select the eaid field and set the same label format as we 
did in previous chapters, which will ensure the readability of the map.

f. Create a new rule  and click on  to open the Edit Rule panel.

g. In Filter, click on  and enter the following expression: @atlas_
featureid = $id but we do not enter any field in Label with to make 
sure that no label is displayed. Then click OK.

h. Click OK in the next menus that follow and check that the conditional 
formatting works as expected.

For the HH point layer style, we will configure similar settings to those of 
the EA polygons. In this case, we only want to show and label the points 
following these two conditions: points that have been selected for this 
hypothetical survey (points where the field Selected is equal to 1) and 
that are located within the EA selected by the atlas.

a. Open HH_atlas_4326. From the Layer Properties panel, go to 
Symbology.

b. Select the Ruled-based option from the top drop-down menu.

c. Double-click on the rule that is currently displayed, or select it and 
click on  to open the Edit Rule panel.

d. In Label, type: Selected HH

e. In Filter, click on  and enter the following formula in order to meet 
the conditions for the HH location layer:

"Selected" = 1 and intersects(@atlas_geometry, $geometry)
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f. Click on Test to check that the formula is working properly.

g. Set the style in order to better make visible the points over the satellite 
image.

h. Create a new rule , click on  to open the Edit Rule panel, 
then click OK.

This time, configuring the labels is simple; you just need to set basic 
labels displaying the HH id.

i. Go to Labels and select the Single labels option.

j. In Label with, select the id field.

k. Set the style by increasing font size and adding a white buffer to 
ensure the correct readability of the HH codes in the maps.

l. Check in the Layout Interface that the conditional formatting works 
as expected and click on  to save the changes to the project.

To finish configuring the style, we will add a Legend to the layout.

a. Go to Atlas_landscape, click on  and draw a rectangle where the 
legend will be located.

b. Select the legend and open the Item Properties menu.

c. Uncheck the Auto update option.

d. Select the Google Satellite entry and click on  to remove it from 
the legend. Use the  controls to order the different elements 
within the legend.

e. Double-click on each of the items to change the titles. In this case, 
we will erase the name of the layers as just the label of each feature 
is a title.
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f. Scroll down across the menu and open the Fonts section. Set the 
fonts for each of the following categories: Title, Group, Subgroup 
and Item.

g. In Columns, we can split the legend into different columns.

h. In Symbol, we can increase or decrease the size.

i. In Spacing, it is possible to control the spaces between the different 
elements in the legend.

7.3 Landscape/Portrait layouts
Looking at the different EAs that we want to map in the project, we notice 
that some of the polygons fit better in a landscape page and others in 
a portrait map.

In this section, you will learn how to configure the atlas to automatically 
distinguish between both orientations and generate both landscape and 
portrait maps.
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The first step will be to generate a field in the Attribute Table that identifies 
whether the polygons fit better in landscape and portrait layouts.

a. Go to the Layers panel and open the Attribute Table of the EA_
atlas_4326 layer.

b. Click on  to open the Field Calculator.

c. Check the Create a new field option.

d. In Output field name, type: orient

e. In Output field type, select the Text (string) option. This is very 
important as we want to store letters in this field.

f. In the Expression dialogue, enter the following formula:
if(bounds_width($geometry)>bounds_height($geometry),’L’,’P’)

g. Click OK and check in the Attribute Table that the new field has 
been correctly generated. We should find a new field named orient, 
populated with L and P characters.

h. Click on  to save the edits and close the editing session.

Now we will configure the Atlas_landscape layout to filter only the EAs 
that match a landscape-oriented page.

a. Go to the Atlas menu and check the option Filter with.

b. Click on  and enter the following expression: "orient" = ‘L’
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c. Check on the atlas toolbar so that now the atlas is only selecting 
landscape-oriented EAs.

The next step involves duplicating this layout, changing the page 
orientation and repositioning all of the map elements.

a. In the top menu of the Layout Interface, go to Layout > Duplicate 
Layout.

b. Name the new layout as Atlas_portrait

c. Right-click in the layout canvas and select Pages Properties…

d. The Item Properties menu will show the page properties (size, 
orientation and background colour).

e. In Orientation, select the Portrait option.

f. Open the Atlas menu.

g. In Filter with, replace the current expression by typing: "orient" = ‘P’
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h. To complete this new layout, we just need to drag and resize all of 
the map elements to make them fit into the new page configuration.

Once both portrait and landscape layouts are ready, we can proceed 
to exporting the maps into image files. The atlas feature allows us to 
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produce all of these maps automatically.

a. In the top menu of the Layout Interface, go to Atlas > Export Atlas 
as Images…. Another option is to click on , which is located in 
the Atlas Toolbar.

b. Select the directory to where the maps will be exported.

c. In the Image Export Options panel, we can configure the settings 
related to the resolution of the images. For this exercise, we will keep 
the default values. Click on Save.

d. A progress bar panel will be displayed showing the number of maps 
already printed over the total.

We will export the maps from both landscape and portrait layout into the 
same folder. It is important to verify that the number of exported maps is 
equal to the number of EAs in the attribute table and that the filenames 
correspond to the EA codes.
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7.4 Atlas-controlled tables
In this section, we are going to create a map layout that includes a table 
of information related to the HHs displayed in the map. The atlas feature 
allows us to synchronize the information included in these tables with 
the area displayed on the map. To conduct the exercise, we need to 
duplicate the Atlas_landscape layout and create the Atlas_landscape_
table following the steps explained in the previous chapter.

a. Reduce the size of the map and move the scale bar to make space 
for the table.

b. Click on  and draw a rectangle where the table will be located 
within the layout.

c. Go to the Item Properties menu and select the Main Properties 
submenu.

d. In Source, select the Layer features option.
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e. In Layer, select HH_atlas_4326

f. Click on Attributes and remove the field HHid by selecting it in the 
Columns display and clicking on .

g. Then sort the fields this way id, name, status, Selected by selecting 
them and using  controls.

h. In Sorting, select id, then select the Ascending option and click on 
.

i. Click OK to save the changes in the table.

If we check on the content of the table and the points displayed in the 
map, we will notice that none of the points match with the ones displayed 
in the map. In addition, when moving from one map to the next one, the 
table remains the same. We need then to set the necessary parameters 
to synchronize both maps and tables.

j. Go to the Feature Filtering submenu.

k. In Maximum rows, set 30 and make sure that the size of the table is 
enough to contain the 30 rows.

l. Check the option Show only features intersecting atlas feature.

m.In Filter with, enter the following expression: "Selected" = 1

n. In Appearance, Show Grid and Fonts and Text Styling submenus, we 
can access the necessary settings to improve the table’s formatting.
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With these settings implemented, the table is synchronized with the 
changing EAs as we cycle through the different maps. With these tables, 
we provide enumerators with ancillary information (the name, address, 
number of inhabitants) that can be useful when conducting fieldwork.



QGIS FOR DIGITAL CARTOGRAPHY IN CENSUSES AND SURVEYS | WORKING WITH RASTERS (TERRAIN DATA)

134

8 WORKING 
WITH RASTERS 
(TERRAIN DATA)

GIS systems mainly operate using two types of spatial data: vector data 
(points, lines and polygons) and rasters. In the previous chapters of the 
manual we have been working with vector data, which, in most of the 
cases, is more suitable for working on statistical data collection activities.

A raster dataset is made up of a matrix (or grid) of pixels. Each pixel or 
cell contains a value that represents the information of the area covered 
in that pixel; for example, the elevation, slope, land-use patterns or 
population density.

8.1 Retrieve digital elevation 
model data from NASA’s 
Earthdata
A digital elevation model, or DEM, is a raster in which the pixels contain 
elevation data from a continuous surface. In this chapter, we are going 
to obtain a DEM from NASA’s Earthdata service through the plugin SRTM 
Downloader.

a. Open a new QGIS session or a new project by clicking on .

b. Load 8_Raster/layers/land_4326.shp to the main canvas.

c. In the Layers panel, right-click on land_4326.shp and select Zoom 
to Layer, so that the map canvas focuses on the layer. This step 
is necessary in order to easily find which canvas or tile we need to 
download from the SRTM repository.

d. In the top menu, go to Plugins > SRTM Downloader. If this plugin is 
not installed, please refer to chapter 2.2 where the plugin installation 
process is explained in detail.

e. Go to Plugins > SRTM Downloader or click on  and the plugin 
menu will be displayed.

f. Click on Set canvas extent to automatically enter the boundaries of 
the work area. With these automatic limits, the plugin will retrieve the 
relevant tiles of the DEM from the SRTM service.
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g. In Output-Path, select the folder where the raster file will be stored 
and check the option Load Images to QGIS.

h. Click Download and the following panel will be displayed requesting 
login details to access NASA’s Earthdata service. If you do not have 
an account for this service, you can quickly create one here: https://
urs.earthdata.nasa.gov/users/new

Once the sign-up process is finished, you will be sent your login details.

i. Fill the Username and Password fields with your user details and 
click OK. A progress bar will show the download process. Once it is 
finished, the raster files will be loaded automatically onto the map 
canvas.

https://urs.earthdata.nasa.gov/users/new
https://urs.earthdata.nasa.gov/users/new
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j. The rasters show the elevations of Puerto Rico. Lighter tones show 
higher elevations and lower elevations are in darker tones.

If for any reason this process does not work on your computer, you can 
access the raster at 8_Raster/DEM/PRI_AST_DEM_comp in the training 
materials included with this manual.
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8.2 Improve raster visualization2

2  Both chapters 8.2 and 8.3 are based on this tutorial: https://opengislab.
com/blog/2018/3/20/3d-dem-visualization-in-qgis-30

With the current display settings, you can quite easily distinguish between 
higher and lower elevations. Nevertheless, it is possible to enhance the 
way this spatial information is represented by creating a 3D model of 
the surface, which in turn makes it easier to interpret the gradient and 
the topography of the terrain. To achieve this, we will overlay a typical 
coloured elevation layer on a hillshade layer underneath. Note that both 
layers are generated from the same DEM raster.

Hillshade

a. Open a new QGIS session or a new project by clicking on .

b. Load 8_Raster/DEM/PRI_AST_DEM_comp

c. In the Layers panel, right-click on PRI_AST_DEM_comp and select 
Duplicate Layer.

d. Open the Layer Properties of PRI_AST_DEM_comp copy (the layer 
that is underneath) and go to Symbology.

e. Go to the Band Rendering submenu, and in the Render type drop-
down menu, select the Hillshade option.

f. In Z Factor, enter 0.00001

g. Check the option Multidirectional. Unlike the traditional hillshade 
models that use one source of light, the multidirectional method 
illuminates the surface from four different directions providing a 
more accurate model.

h. In the Resampling submenu, go to Zoomed. For the In option, set 
Bilinear; for the Out option, set Average; in Oversampling, set the 
value at 2.00

https://opengislab.com/blog/2018/3/20/3d-dem-visualization-in-qgis-30
https://opengislab.com/blog/2018/3/20/3d-dem-visualization-in-qgis-30
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i. Click OK to save the changes in the symbology and check the map 
canvas to make sure that your raster looks similar to the image 
below.

j. Right-click on the layer and select Rename Layer. Change the name 
to indicate that this layer is a hillshade (e.g. PRI_AST_DEM_comp 
hshade).

DEM displayed with an elevation colour ramp

a. Open the Layer Properties of PRI_AST_DEM_comp (the layer on 
top) and go to Symbology.
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b. Go to the Band Rendering submenu, and in the Render type drop-
down menu, select the Singleband pseudocolor option.

c. Next to Color ramp, click on the arrow located on the right to open 
the drop-down menu. Select the Create New Color Ramp option.

d. In the Color ramp type panel, select Catalog: cpt-city option and 
click OK.

e. In the Cpt-city Color Ramp panel, select the Selections by theme 
tab, go to the Topography section and select one of the colour ramps 
available. Then click OK.

 

f. Go back to the Symbology menu, and in Interpolation, select 
Discrete.

g. Go to Min / Max Value Settings and set 0 m of elevation to be a blue 
colour to represent the ocean.
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h. In Color rendering, go to Blending Mode menu and select the 
Multiply option.

i. Go to the menu on the left and select Transparency, then set the 
Global Opacity to 80%. Click OK and check in the map canvas the 
results of these new symbology settings. Do not forget to save the 
changes to the project by clicking on .

 

The map now contains rich information regarding the terrain. 
Consequently, it is now possible to identify the elevation by virtue of 
the different shades and to read the shapes of the relief thanks to the 
hillshade.
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8.3 Working with 3D map views
In QGIS 3, the 3D visualization tool is native, whereas in previous versions, 
3D visualizations were a function of an external plugin, Qgis2threejs. 
3D maps are a good way to display in the layouts additional information 
related to the landscape.

Prior to working in the 3D view, we are going to prepare our map canvas.

a. Load 8_Raster/layers/roads.shp and put it on top of the rasters in 
the Layers panel.

We will set a new symbology for this line layer so that it is easily identifiable 
on the map. 

b. Open the Layer Properties panel of roads.shp and go to Symbology.

c. Select the Single symbol option, as we will display all the roads using 
the same symbol.

To represent the roads, we will set a pale grey line with dark grey borders. 
We will construct this symbol by overlapping a pale grey line over a dark 
grey one. Then we will set different widths for both lines to create the 
border effect.

d. Click on  to add a new symbol layer in the symbol panel.

 

e. Select the line on top, then set a pale grey Color and a 0.4 mm Stroke 
width.

f. For the line underneath, set a dark grey Color and a 0.5 mm Stroke 
width. 
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Now that we have all the layers of our map cleanly represented in our 2D 
map, we can start working with the 3D view.

a. In the top menu, go to View > New 3D Map View. An error message 
will be displayed informing us that the 3D view is not supported on 
an unprojected CRS, like the default QGIS CRS.

b. To change the CRS, go to Project > Properties and select the CRS 
menu. It is also possible to access this menu by clicking on the 

 icon located in the bottom-right corner of the 
screen.

c. In the CRS menu, select a projected CRS. For this exercise, EPSG: 
3857 will work. Select one of them and click OK.

d. Try View > New 3D Map View again. A new 3D Map window will 
appear.

e. Click on  to open the 3D Configuration panel.

f. In Elevation, select one of the two DEMs open in the project. The 
DEM will act as the data input to render the relief volume displayed 
in the 3D view.

g. In Tile resolution, we will increase the value up to 50 px, as the region 
we want to display is relatively small.

h. In Map tile resolution, set the value to 200 px (for better-quality 
rendering) and click OK. If you notice that your computer takes too 
long to render the 3D view, it is recommended that you restore the 
default values.



QGIS FOR DIGITAL CARTOGRAPHY IN CENSUSES AND SURVEYS | WORKING WITH RASTERS (TERRAIN DATA)

143

i. The navigation controls within the 3D view are as follows:

- Click to pan the map.

- Hold Shift + click or click with the mouse wheel to rotate the view.

- Roll the mouse wheel to zoom in/out.

If you want to create a realistic landscape, you can put a satellite image 
overlay above the DEM.
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8.4 Assign elevation data from 
DEM to point layer
In this exercise, we are going to classify HH location waypoints according 
to their altitude. This will allow us to view the HH locations in terms of 
their vulnerability relative to potential natural disaster events linked to 
sea-level rise (tsunamis, storm surges, cyclones). We are going to obtain 
the elevation information from the DEM and add it to a point shapefile as 
a new field in the attribute table.

a. Load the layer 8_Raster/layers/HHLoc_4326.shp in the map canvas.

b. In the top menu, go to Plugins > Manage and Install Plugins and 
check if the Point Sampling tool is installed. If not, proceed with the 
installation of the plugin.

c. Once it is installed, go to Plugins > Analyses > Manage and Install 
Plugins or click on  to open the plugin. The Point Sampling Tool 
panel will be displayed.

d. In the Layer containing sampling points drop-down menu, select 
the layer HHLoc_4326

e. In Layers with field/bands to get values from, select HHLoc_4326 
to keep the fields from the point layer and PRI_AST_DEM_comp, the 
layer containing the elevation data (use Ctrl + click to select multiple 
layers).

Note that the layers have to be checked as visible in the Layers panel to 
make them available in the plugin menu.

f. In the Output point vector layer, select the location and the name 
of the resulting point layer (e.g. HHLoc_Elev_4326.shp). Then click 
OK to start the process.
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g. The point layer containing the elevation data will be automatically 
loaded onto the map canvas. Open the Layer Properties panel and 
go to Symbology.

h. In the top drop-down menu, select the Graduated option.

i. In Column, select the field containing the elevation data.

j. In Color ramp, select a suitable ramp to display vulnerability. In the 
example, we have selected RdYlGn, located within the All Color 
Ramps submenu.
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k. Click on Classify, select the classification Mode and the number of 
Classes and set the thresholds and labels for the different ranges.

The result will be a cloud of points represented on the map according to 
the degree of vulnerability determined by the altitude at which the points 
are located.
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9 DATA MANAGEMENT 
AND STORAGE: 
SPATIAL DATABASES – 
GEOPACKAGE

In this chapter, you will learn how to store and manage 
different projects and datasets by using two different 
approaches. The first is based on the use of projects and 
folders and the second one relies on the use of spatial 
databases.

9.1 Data management and 
storage using projects and 
folders
This method is easier for beginner GIS users as it stores data in a 
folders and subfolders structure. In general, this technique works for 
small projects. However, this simple method may be insufficient when 
undertaking large and complex projects (e.g. large numbers of datasets 
from various sources, with different formats and levels of processing).

When using the projects and folders approach, it is necessary to choose 
the criteria by which we will classify the project data into folders. There 
are many different ways to do this and there is not necessarily one correct 
solution. For example, you can group by data types (e.g. vector, raster, 
table), by project (e.g. census, listings, year), or by topic (e.g. HH locations, 
boundaries, rivers, facilities).

You will find the hypothetical example of Malawi, stored in the training 
materials folder, which accompanies this manual.

a. Open 9_data_management/MWIProject.qgz

b. Either using the QGIS browser or the default file manager in your 
operating system, open the 9_data_management folder and study 
how the data is organized across the different folders and subfolders. 



QGIS FOR DIGITAL CARTOGRAPHY IN CENSUSES AND SURVEYS | DATA MANAGEMENT AND STORAGE: SPATIAL DATABASES – GEOPACKAGE

148

Note that the project file is located next to the layers folder. The 
layers folder contains subfolders that store data by type: raster, 
shapefile. The way the data will be arranged will depend on the user’s 
preferences, the nature of the project, etc.

A dependence on folders can make sharing projects among users a 
very challenging process if we want to preserve workspace settings, like 
symbology and labels. If users are not familiar with GIS software, the 
sharing process can quickly become unmanageable and complicated.

The plugins QConsolidate and QPackage, both available in QGIS, can 
package layers and projects to allow projects and folders to be shared, 
but remove any data storage structures in the process.

To install both plugins, we will follow these next steps:

a. On the top menu, go to Plugins > Manage and Install Plugins… and 
select the All menu on the left side of the panel.

b. Go to Settings and check the Show also experimental plugins 
option.

c. In the search bar, type Qpackage. Select the plugin Qpackage and 
click on Install plugin.

d. In the search bar, type Qconsolidate3, select the QConsolidate3 
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plugin and click on Install plugin.

As both plugins work in a similar way, it is only necessary to learn how 
to use one of the plugins. We will use QConsolidate3, as it is currently 
more stable in the QGIS 3 environment.

a. Open CookProject.qgz. You will notice that all of the layers have been 
configured with specific symbologies and labels and that a satellite 
image background has been added.

Because of a bug that has not yet been resolved, we need to save the 
project using the .qgs extension.

b. In the top menu, go to Project > Save as or click on .

c. In the Save Project As panel, in the Save as type drop-down menu, 
select the QGIS files (*.qgs ) option.

Once the project is saved with a .qgs extension, we will start using the 
plugin to package and share the project and the layers.

d. In the top menu, go to Plugins > QConsolidate3.

e. In Project name, we can change the name of the project to be shared 
if necessary.

f. In Output directory, set the new location for the package.

g. In the drop-down menu below Output directory, select the SHP 
option. You will notice that there is an option to convert all the layers 
into GeoPackage format; we will explore this format in the next 
section.

h. The option Consolidate in a Zip file allows the project and layers to 
be stored in a zip file. In this instance we will not select it.

i. Click OK.
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j. The plugin will store the project in the specified location and will 
create a folder named Layers where all the project’s layers will be 
stored. This means that any data structure that was put in place 
before will be replaced by a simpler one set by the plugin.

QPackage works the same way, but there are a few differences with 
QConsolidate3.

• In QPackage, it is possible to select which layers will be packaged 
in the process.

• In QPackage, it is possible to select the target CRS for the packaged 
project.

• QPackage saves both layers and project file in the same file.

• There are issues with QPackage when packaging rasters (this 
error had not been resolved while this manual was being written in 
02/2020).

• When QPackage packages the layers and the project, it saves the 
current project session to the new location. We have to be careful and 
open the original project again in case we want to keep working on it.
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9.2 Data management and 
storage using spatial databases 
(GeoPackage)

3  GeoPackage official website: https://www.geopackage.org/

4  Documentation QGIS 3.4: https://docs.qgis.org/3.4/en/docs/training_ma-
nual/basic_map/vector_data.html?highlight=geopackage

Generally, we have opted to use the ESRI shapefile (.shp) for vector 
layers in this manual. We made this decision so that the manual could 
be used by beginner to intermediate GIS users. As the shapefile is the 
most common format in ESRI and QGIS environments, basic users are 
likely to already be familiar with it.

However, this does not make the .shp format the best support when 
working with vector layers. In this chapter, we will present other 
alternatives that have significant advantages over the shapefile format.

9.2.1 GeoPackage format

"GeoPackage is an open, standards-based, platform-independent, 
portable, self-describing, compact format for transferring geospatial 
information."3

A more accessible definition of the GeoPackage format can be found in 
the QGIS documentation: "the GeoPackage open format is a container 
that allows you to store GIS data (layers) in a single file".4

The main advantages of using this format when managing our vector 
data, and in some cases raster data, are as follows:

It is OPEN source.

QGIS has been switched to work by default with GeoPackage even if it 
still perfectly supports shapefile and other formats.

GeoPackage can store several layers with different geometries (points, 
lines, polygons) using different CRS in a SINGLE FILE. When working 
with shapefiles, it is necessary to create at least three files to store one 
single layer (see chapter 3.1).

GeoPackage is compatible with other GIS software packages and 
programming languages (e.g. ESRI, Python, QGIS, R, GDAL).

The workflow of GeoPackage (editing, selection, attribute table, 
symbology …) is the SAME as with shapefile.

https://www.geopackage.org/
https://docs.qgis.org/3.4/en/docs/training_manual/basic_map/vector_data.html?highlight=geopackage
https://docs.qgis.org/3.4/en/docs/training_manual/basic_map/vector_data.html?highlight=geopackage


QGIS FOR DIGITAL CARTOGRAPHY IN CENSUSES AND SURVEYS | DATA MANAGEMENT AND STORAGE: SPATIAL DATABASES – GEOPACKAGE

152

In the following exercise, we will follow the workflow process of grouping 
several shapefiles (point, line and polygon), a raster and their styles, into 
a single GeoPackage file.

a. Open 9_data_management/MWIGeopackage.qgz

In this project, you will find eight vectorial layers in shapefile format, plus 
one raster. Each layer already has a preconfigured symbology stored 
in the project file. We are going to put together these shapefiles in a 
group in the Layers panel. We do this in order to differentiate the pre-
existing shapefile layers from the ones we will later create and store in 
a GeoPackage.

b. At the top of the Layers panel, click on  to create a new layer 
group. Name it Shapefile and drag all the existing layers within the 
group.

Next, we will create the GeoPackage file. There are three ways to do this:

1. On the top menu, go to Layer > Create Layer > New GeoPackage 
Layer…

2. In the Browser panel, right-click on  and select 
Create Database.

3. In the side menu bar located on the left side of the interface, click 
on .

For all of the three cases, the same New GeoPackage Layer menu will 
be displayed.

c. In Database, select the location for the new database and its name 
(e.g. 9_data_management/database/MWI.gpkg).

d. In Table name, leave the current text.

e. In Geometry Type, select the option No Geometry.

We have to create this table as the GeoPackage file needs at least one 
item to store when it is first created. We will remove this item later from 
the database.

f. Click Ok. In the Browser panel, right-click on , 
select New Connection and open MWI.gpkg from its location.

g. In the Browser panel, MWI.gpkg will be displayed under 
. After undertaking any modification, it is 

recommended that you click on  to refresh the folders.

Now that we have created the GeoPackage file we will package all the 
vector layers and the raster inside. There are two main ways to achieve 
this:
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1. Browser panel

h. Drag MWI_HealthFacilities_4326 from the Layers panel to the MWI.
gpkg folder located in the Browser panel.

i. The following panel will be displayed and the layer MWI_
HealthFacilities_4326 will appear in the GeoPackage file tree.

2. DB Manager

The DB Manager is one of QGIS’s core plugins and is intended to be the 
main tool to integrate and manage spatial database formats supported 
by QGIS (PostGIS, SpatiaLite, GeoPackage, Oracle Spatial, Virtual layers) 
in one user interface.

a. In the top menu, go to Database > DB Manager.

b. In the DB Manager menu, in the Providers window, click on 
to show the connections available. If MWI.gpkg 

is not available, right-click on , then select New 
Connection and open the GeoPackage file from its location.

c. Double-click on MWI.gpkg to display the items already included in 
the database.

d. Click on Import Layer/File, and the Import vector layer panel will 
show.

e. In Input, select MWI_Roads_4326 

f. In table, select the table from the same layer as in Input; in this case, 
MWI_Roads_4326

g. Check the Primary key option and click OK.
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Add the rest of the vector layers into the MWI.gpkg and practice both 
methods to familiarize yourself with them. There is one thing we need to 
keep in mind, and it is that rasters cannot be added using the DB Manager, as 
for the moment this plugin does not support raster layers. You will therefore 
need to use the dragging method. Once you have finished, your GeoPackage 
file tree should be structured as in the image below.
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h. Now we can delete the empty table M that was created before. In the 
Browser panel, right-click on the M table and select Delete Layer ‘M’.

Now that we have packaged the layers into the GeoPackage, we will add 
them into the map canvas.

a. From the Browser panel, in the GeoPackage branch, select MWI.
gpkg and either double-click on each layer or drag them into the map 
canvas. Make sure when adding the layers from the Geopackage 
that they remain outside the layers group created at the start of this 
section.

Next, we are going to copy the styles from the shapefiles and store them 
as a table in the GeoPackage file. This ensures that the layers will be 
displayed using the same symbology, even if they are opened in another 
QGIS project.

b. Right-click on the layer MWI_HealthFacilities_4326 (the one inside 
the shapefile group) and select Styles > Copy Style > All Style 
Categories.

c. Right-click on the layer MWI_HealthFacilities_4326 from the 
GeoPackage file and select Styles > Paste Style > All Style 
Categories. Our layer will get the new symbology and labels settings.

d. Go to the Layer Properties panel. In the Symbology menu, click on 
the Style button (bottom-left corner), select the Save Style option 
and the Save Layer Style panel will be displayed.
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e. In the Save style drop-down menu, choose the In database 
(GeoPackage) option.

f. In Style name, set a name for the style (e.g. HealthFacilities), add a 
description, if you find it necessary, and click OK.

Follow the same steps to copy the styles from the shapefile vector layers 
onto the GeoPackage equivalents and save the styles in the database. 
You can do this for each of the layers except for the raster (we will explain 
why at the end of the chapter).

g. Open the DB Manager, select the GeoPackage and deploy the 
MWI.gpkg database. You will find a new table named layer_styles 
that now contains the styles for the vector layers contained in the 
database. You can check the content of the table by selecting it and 
clicking on the Table tab on the right side of the menu.
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h. Open a new session of QGIS and try to load the layers contained in 
the MWI.gpkg database. Now the layers will be displayed with the 
symbology settings stored in the GeoPackage database.

Although GeoPackage can store rasters, it cannot store their styles. This 
means that the way we will manage the styles is the same as before: 
either we store the style with the project, or we save it with a .sld or .qml 
file that can be loaded once the raster layer has been opened.

As mentioned at the beginning of the chapter, when working with vector 
layers stored in a GeoPackage database, the workflow in the QGIS 
environment is the same as if we were working with shapefiles. No new 
skills or processes need to be learned to work with GeoPackage apart 
from the basics about how the format stores the information.
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10 METADATA

10.1 Populate metadata 
(standards and compatibility)
Metadata is information about data. Metadata records and documents 
important information about a dataset, such as the author, description, 
abstracts, keywords, updates, dates of creation/update, etc.

QGIS 3.x uses metadata differently compared to QGIS 2.x. At the time 
of writing (07/2019), the QGIS metadata editor does not support either 
ISO 19115 or ISO 19139 standards; however, its structure operates in a 
similar way to these standards.

In this example, you are going to populate the metadata file for a schools-
unicef-2004 slayer containing the school locations in. We will complete 
the metadata as if we were the authors and owners of this dataset. The 
dataset has been extracted from https://data.humdata.org/. You will find 
To add into metadata.txt file alongside the layer that contains information 
that can be added on the layer’s metadata.

a. Load 10_metadata/layers/schools-unicef-2004.shp, open the 
Layers Properties panel and go to Metadata.

The metadata menu helps streamline the data-entering process and will 
create a metadata summary for the layer.

b. Identification describes the basic attribution of the dataset (e.g. 
parent identifier, identifier, title, type, language, abstract).

https://data.humdata.org/
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c. Categories. The metadata editor includes ISO categories. Select the 
category from the ISO categories panel and click on  to add it 
into the Chosen categories panel. You can add custom categories 
by clicking on .

d. Keywords are used to help data retrieval processes follow standard 
concepts and vocabulary. In this case, we have verified the 
terminology via the GEMET website while adding one more concept 
and the related keywords.
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e. In the Access section we will include all the information related to 
licenses, rights, fees, and other constraints. In the link that follows, 
we can find information and guidelines to better understand how to 
complete this section:

https://theodi.org/article/publishers-guide-to-open-data-licensing/

f. The Extent tab comprises spatial (CRS, map extent, altitudes) and 
temporal information. Click Set CRS from layer and the information 
will set according to the preconfigured layer properties. For the extent, 
you can either fill it manually or use one of the three options available: 
Current Layer Extent, Calculate from Layer or Map Canvas Extent.

https://theodi.org/article/publishers-guide-to-open-data-licensing/


QGIS FOR DIGITAL CARTOGRAPHY IN CENSUSES AND SURVEYS | METADATA

161

g. In Contact you should include owners and other related persons or 
institutions responsible for the dataset.

h. Within the Links tab we can include ancillary resources and related 
information, such as online databases, catalogues or documentation.

i. The History section documents corrections, modifications and 
versions of the dataset.
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j. Validation verifies that we have entered the minimum information 
required to meet metadata standards. The minimum requirements 
are identifier, language, type, title, abstract, links, contacts, license, 
CRS and extent.

k. Go to the Information tab and you will see that all the information 
added into the Metadata section has been included automatically.
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By default, the metadata will be stored alongside the project file. However, 
this means it will not be accessible when opening this layer into a different 
project. To solve this, we will follow these steps:

l. In Metadata, click on Metadata located at the bottom-left corner and 
select Save Metadata.

m.Give the file the same title as the layer (schools-unicef-2004.qmd). 
The extension .qmd will be automatically assigned. It is important 
to save this .qmd file alongside the other layer files (.shp, .shx, .dbf, 
etc.). This allows the program to retrieve automatically the metadata 
for the layer the same way it does for the other extensions containing 
the attribute table or the projection information, for instance.

In the case where we are using either a different layer format 
(GeoPackage, KML) or the metadata is stored separately or with another 
name, we can still add manually the metadata to the layer.

n. In Metadata, click on Metadata located at the bottom-left corner 
and select Load Metadata. Select the .qmd file that contains the 
metadata for our layer and click OK. The metadata will be displayed 
in the Information section.
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